Currently running max/msp has wrong architecture

    Max For Live

    porya's icon
    porya's icon
    Mar 26 2013 | 12:38 pm
    I have live 9 and max 6.1 32 bit installed but when i want to edit a device in max for live i get this message in live status bar, "Currently running max/msp has wrong architecture - expected 32bit, found 64bit " max lunches anyway bit very unstable and crashes ! anyone has a solution for this ? i installed max 64bit but uninstalled it before installing the 32 bit version

    • kflak's icon
      kflak's icon
      Mar 31 2013 | 8:29 pm
      Same problem here. I tried unchecking and rechecking the "Open in 32-bit mode" option in the finder, but I'm still getting the same message. My plugs don't even open in Max... Would be very grateful for a solution. I'm on Mac, by the way... Don't know if that makes a difference...
    • Andrew Pask's icon
      Andrew Pask's icon
      Andrew Pask
      Apr 01 2013 | 1:30 am
      OP - please supply system details. If you believe you have the versions matched then please email full details into support.
      Mac MFL users - please make sure you have all Live installer DMGs unmounted. Please note the Mac version of Max 6.1 is FAT - both 32 and 64 bit versions are installed from the same installer.
      If this is not it, then please email all details into support
    • kflak's icon
      kflak's icon
      Apr 01 2013 | 7:10 am
      I downloaded Live 9.0.2. to see if that would make a difference. Which it certainly did, but not in a good way: Now every time I try to load any m4l plugin Live crashes instantly. I'll get in touch with support to see what the hell is up... System: MacBook Pro 2.66 GHz i7, OS 10.8.3., Max 6.1.0
    • kflak's icon
      kflak's icon
      Apr 01 2013 | 7:18 am
      Solved! I updated to Max 6.1.1, and now everything seems to be back to normal again, including being able to edit plugins in Max...
    • prillip's icon
      prillip's icon
      Jan 07 2014 | 2:54 am
      I am new to this and having the same problem. Should I just install the 64 bit version of Max instead? will this solve the problem? I'm aware that it has not been fully developed yet.
    • jibiz's icon
      jibiz's icon
      Feb 16 2014 | 10:29 pm
      hi! i had a similar problem here. i had to install max 32bit to use some 32 bit objets. but since i did max 4 live wont open any plugin. it says that "the selected application max couldn't be charged. a 64 bits version is probably requiered. can't i run max for live with my 32 bit max?
    • Stephane Morisse's icon
      Stephane Morisse's icon
      Stephane Morisse
      Feb 18 2014 | 7:32 am
      Yes you can !
    • Graham Dunne's icon
      Graham Dunne's icon
      Graham Dunne
      Feb 16 2015 | 3:20 pm
      I'm actually having a problem with this using Live 9.1.7 and Max 7.0.1. I've had the 'expected 64bit, found 32bit' message recently and then reinstalled everything to try and sort it. Today, having had no problem all weekend, I'm getting the above message again. It's a pain and probably means I should use Max 6 in Live in order to edit devices for the moment.
    • geddy's icon
      geddy's icon
      Dec 16 2015 | 3:31 pm
      I had this problem with Live 9.5 and Max 7.1.0 (no the standalone version). I had to reinstall, and then it recognised that I was using the 64bit version.
    • eport's icon
      eport's icon
      Dec 17 2015 | 3:26 pm
      Hi everyone!
      Same problem with Live 9.5 64-bit and Max 7.1.0 in a Macbook pro 2,6 GHz Intel Core i7 - 16 Go 1600 MHz DDR3.
      If both versions (32 and 64) comes together in Max and this problem exists since several versions of Live I don't really understand where the problem comes from.
      ANY IDEA??
    • Rich Meyer's icon
      Rich Meyer's icon
      Rich Meyer
      Aug 20 2021 | 11:13 am
      I was getting the same error on Live 9.7 (mac 10.13.6) High Sierra - Once I uninstalled and re-downloaded MaxLive 7.3.4 and re-installed I was able to open and edit modules again luckily!