"Curve Perform" Causes Crash

    Mar 16 2009 | 4:47 am
    So here is a part of a large patch of mine I built today. I stripped it down to only what I need to show my problem. Something really bizarre and inexplicable is happening. What you need to do is just turn the sequencer on (in the red patch in the middle), and as the sequencer is running, with DSP turned on, hold down your mouse and scroll across the matrixctrl, so you toggle a lot of steps.For me, this causes a crash every time. The crash always occurs in the thread that contains "curve~ perform" (Thread 7, usually). I have tried changing the curve~ object within the [onehit~] patcher that the crash is occuring to a line~ object - same crash happens except it's "line~ perform". I am on Max OS X 10.4.11, Intel Processor, Macbook Pro 17".
    I have no clue what could be causing this. My [onehit~] patch works fine on its own and within other patches. It's just in this patch that I get this bizarre crash when I have too many states toggled on the matrixctrl.
    Ah yes, I should metion that the patch you want to open and run is the patch titled "BasicMatrixCtrl2".
    Thanks for any help. In the very least, could people try running this patch and tell me if Max crashes on them too?

    • Mar 16 2009 | 11:17 pm
      curve~ crashes because you send bad lists to it. You send NaN as target time. I fixed it for the next incremental or so, but in the meantime you might want to clip your time value to make sure that it's a positive value.
      Thanks for the example.
    • Mar 17 2009 | 2:29 am
      thanks for the reply ej. i emailed C74 support and got the same reply. Just stuck a [sel 0.] before the [/ 1.] in my [onehit~] patch, connected the right outlet to [/ 1.] and voila, problem solved
      [onehit~] was working in my other patches because i wasn't automating playback speed, so the [/ 1.] object never received a 0.