Cycle~ not reading buffer max 5

    Feb 14 2012 | 7:15 pm
    Hi folks,
    I've searched through the posts, examined the documentation and tried every permutation I can think of and I can't get this seemingly simple patch to work. I'm following one of Peter Batcheler's fantastic tutorials: Buffers and wavetables ( I can't get the cycle~ object to read through my buffer~. I know it's something obvious so sorry in advance, it's just driving me insane.

    • Feb 14 2012 | 7:30 pm
      if you make the buffer much smaller, i.e. 11.61 ms, than it will work. cycle works with buffers of 512 samples (NOT MS!!!) as stated in the help file. Also see the 4. option in the cycle~ helpfile.
      "The cycle~ object is an interpolating oscillator that reads repeatedly through one cycle of a waveform, using a wavetable of 512 samples."
      the youTube video you are referring to is using a buffer of 11.7, you copied the sample number 512 as the ms!
    • Feb 14 2012 | 7:35 pm
      Ha! I'm an idiot. Cheers Sebastian :)
    • Feb 15 2012 | 3:35 pm
      Note that you can - use the sizeinsamps message to set the buffer to a certain size in samples - In Max 6 you can use big buffer windows for cycle for extra fun and precision.
    • Feb 15 2012 | 3:52 pm
      Thanks Emmanuel that's really useful!