depth_enable & transparency problems


    Jan 31 2013 | 9:45 pm
    Hi,
    In the patch below, there are three elements: plane, sphere and a "noise mesh". The plane is transparent but I can not see both remaining elements through it. First the mesh wasn't visible behind the (transparent) plane, now I can't see the sphere. And the change happened as I restarted the patch...
    I am running some old mac book pro and the latest version of Max.

    • Jan 31 2013 | 9:53 pm
      if you want to overlay transparent shapes, you must do three things. disable @depth_enable enable @blend_enable control drawing order explicitly with @layer attribute, back to front. so @layer 1 objects will be behind @layer 2 objects.
      if you don't specify layer attribute, the order the objects are drawn is unknown, and will possibly change as you add objects to your scene.