DmxUsbPro-object with Enttec device: no connection in Live?


    Dec 21 2011 | 7:56 pm
    Hi,
    For some years now I use the DmxUsbPro-object in Max to communicate with my Enttec DmxUsbPro-device in order to send and recieve data. I never had any problems with this application.
    When Max For Live came out, I integrated this DmxUsbPro-object in a Live-instrument, so I could control all dmx-controlling knobs and buttons directly in Live, without the unhandy midi-connection between Max and Live I used before.
    This worked fine, until some time ago.
    (I didn't have the time yet to solve this problem, but it is over 8 months old...)
    Now, when I open the MaxForLive-instrument in Live, I can never establish a connection with the Enttec-hardware.
    When I open the MaxForLive-patch in Max, there is no problem, but no matter what I do: I can never connect with the hardware in the Live-environment. Thus, I can no longer control dmx-controlling knobs and buttons directly in Live.
    This is a huge obstacle, because I used to assign certain knobs on my APC40 Live-controller specific to dmx-controlling functions: sound and light controlled on one board you see...
    I searched the web, but didn't even find someone with a simular problem yet.
    You all are my last hope...
    Thanx in advance,
    Laurens

    • Dec 21 2011 | 9:29 pm
      Can't help you until I see the patch, all I can say is that it is working for me.
    • Dec 23 2011 | 1:19 am
      Well... it is just the standard patch made by Olaf Matthes; in attachment!
    • Apr 25 2012 | 8:01 pm
      Any possible progress or workaround with the above matter?
      I'm also here banging my head on the walll ... The DMXUSBPRO works great in the m4l plugin window when edited in max domain but when I save it and try to use it as a m4l plugin in live the device is not found...
      I hwould hate to run max on the background just for this.
      Thanks!!!