draw_piwels replacement for background drawing


    Jun 21 2012 | 7:54 am
    Hi,
    I'm really lost here and can't seem to get the logic of what I want to do.
    It seems that in MAX6 the draw_piwels command to the jit.gl.render doesn't function anymore.
    It' like to have a static gradient background that doesn't move along when I move the/flip/rotate the camera of my scene.
    I think thi scan be done by using jit.gl.nodes and jit.gl.camera to render the 'in front' objects and use a different jit.gl.node to render a static fixed position jit.gl.videoplane in the back
    However, I simply can't get it to work and have a few problems when trying, like textures not rendering and so on.
    Any one can shed some light on this?
    thx in advance

    • Jun 21 2012 | 6:39 pm
      hello. to draw a background layer, simply use a jit.gl.videoplane @transform_reset 2.
      you may also want to set @depth_enable 0, or set the @layer to some low negative value, causing it to draw first.
    • Jun 22 2012 | 7:13 am
      Thanx Robert,
      so using nodes is not an option here?
      best
      pieter
    • Jun 22 2012 | 4:46 pm
      i'm not sure why you think that. you can use jit.gl.node and jit.gl.videoplane together.