Edgeblend between projectors


    Aug 06 2013 | 9:38 am
    Hello I am trying to create a solution for edge-blending between several projectors.
    I have come this far, but I do not understand why it is not working with jit.gl.hap?
    I get some images out using jit.qt.movie, but I would like to use hap.
    What Im I doing wrong?

    • Aug 12 2013 | 3:39 pm
      looks like it's simply a typo.
      you have "jit.gl.hap sub-node.ctx" rather than "sub-node-ctx"
    • Aug 12 2013 | 7:47 pm
      Still wont let me capture to the node. Should I not enable capture parameter for the node?
      I might be confused of its function.
      What I want to achieve is:
      1. send several textures to individual jit.gl.mesh objects.
      2. Capture all of these textures by a jit.gl.node object
      3. send the combined texture to two or more jit.gl.videoplane objects for overlap and edgeblend when using several projectors.
      But when I enable capture, everything goes black.......
      I thin I have misunderstood some concepts here? or?
      Thanks for you help.
    • Aug 12 2013 | 10:23 pm
      your patch works perfectly over here with the latest 6.1.3 on the Mac.
      although i don't have your gl.edgeblend shader, so i can't really say what that's doing.
      if you still can't get it to work, please post your relevant system specs.
    • Aug 13 2013 | 5:46 am
      Hello Rob,
      After trying out the different shaders with edgeblending I still get no image. I removed all edge-belending objects, and still no image.
      I have Max 6.1.3
      Running on OSX version 10.8.4
      Processor 2.6 GHz Intel Core i7
      16 G Ram
      SSD hardrive
      Retina display mac.
      My latest try:
    • Aug 13 2013 | 5:30 pm
      when i start your patch, i see the following (attached as an image).
      you see something different?
      try replacing the gl.hap objects with a qt.movie -> gl.slab combo.
      what is your graphics card?
    • Aug 13 2013 | 5:49 pm
      This is wired. I just did a re-install of my computer. Everything from scratch, and now I get the same image as you.........
      go figure....
      Problem solved.