encapsulated subpatch for jit.world render and broke patch


    Jan 24 2019 | 12:33 am
    Hi I have encapsulated my jit.world and whatnots into a subpatch which then broke my patch. I'm still recieving a bang in the main patch from the world, so not sure what's going on. Any ideas? thanks in advance

    • Jan 24 2019 | 4:56 pm
      Have you made the OpenGL objects in your main patch refer to the world using the name? For instance you have named the jit.world 'this' so gl objects need to be pointed to that world e.g. [jit.gl.gridshape this @shape sphere] .
      I usually avoid putting the jit.world into a subpath as I have run into problems before with how objects attach themselves to various contexts.
    • Jan 24 2019 | 5:04 pm
      this should be working fine, try restarting Max? the only problem with this approach is that if you're editing the encapsulated patch while having your main patch open, you'll end up with two contexts with the same name and you'll probably get a message like "name this already in use. ob3d does not allow multiple bindings"
    • Jan 24 2019 | 8:18 pm
      yeah, I have all of them pointing to the name, except a jit.gl.node and videoplane which draws to the node. If I try to name those 'this' it does say I can't have multiple bindings., but that is whether I have the subpatch or not.
      I've tried restarting and it still doesn't work so I am for now just going to keep it all in the main patch. Thanks for your help!
    • Jan 25 2019 | 6:21 pm
      the jit.gl.node should also be bound to the jit.world. e.g.: [ jit.gl.node this @name mynode ] [ jit.gl.videoplane mynode ]