"error parsing patcher file" broke my patch

    Jun 11 2008 | 9:24 am
    Very strange and unsettling, I suddenly can't open a file I've been working on the past two days. There's 6 versions of it that I've archived, and I can't open any of them. Here's the error messages from trying to open #1 and #6:
    error parsing patcher file led_bman_6.maxpat parsing string, possible missing quote: line=5105, char=21, text='... { "maxclass" : "message", "text" : "' error parsing patcher file led_bman_1.maxpat parsing string, possible missing quote: line=5659, char=21, text='... { "maxclass" : "message", "text" : "'
    Note: the rectangle character, in the Max window, isn't there: it looks like this:
    text='... { "maxclass" : "message", "text" : "'
    or maybe it's "text" : '"
    Searched for both those possibilities in max-text and jEdit, nothing. searching for "text" : " brought up hundreds (it's a big patch). And the "line numbers" aren't right either.
    Sooooo.... this is really disturbing.... will this possibly happen again? and is it fixable? How did that weird character get in there (or) where did the closing double-quote go??
    Help! ! ! !

    • Jun 11 2008 | 10:19 am
      There is probably a non-printable control character at the line indicated by the error message. Open the .maxpat file in a text editor like TextWrangler and delete the non-printable.
    • Jun 11 2008 | 10:54 am
      Achh, I kinda panicked and posted before enough searching around. I saw your other post and am hunting down the 'gremlin'....
      Hope this doesn't occur too often, wonder how it gets there..? Maybe a typing error goes unnoticed while filling in the Inspector fields, or in a comment or message box like you said. I wonder what control-characters have the ability to do this, might be a good test.
      thank you thank you for the fix! ! -CJ
    • Jun 12 2008 | 1:31 am
      I spoke too soon, am having a heck of a time finding a text editor for Windoze which can do this. Either they don't show the characters, or they do but there's no search for these specific ones, or they don't have line numbers. Tried jEdit, BabelPad, Notepad++, and Word... nothing has the combination I need to take care of this!
      I wonder if it's the same character all the time... do you remember which one it was/Ascii code? Maybe I need to make a patch to remedy this... spew raw bytes, select the control characters, keep track of how many/what kind/what line #/what char #, all in colls. Argh. If there's a better program for this I'd love to know, thanks!
    • Jun 12 2008 | 2:35 am
      Sorry for the continued blathering, but hopefully this will be of use to someone in this situation. Found TotalEdit (Windows) and am able to search for hex codes using their regexp. Discovered two control chars: hex 01 and 05, right next to each other (though on line 2665, not 5105 as claimed in the Max window... something about the formatting makes Max think it's elsewhere?). I made them spaces instead, voila, patch works again.
      So the next question is: which control characters are possible to cause this (so one can do a range regexp to find them, while not choosing Tab, CR, LF, etc.)... and of course... where did they come from in the first place?
      Anyway, thanks for pointing me in the right direction. Hope this issue gets addressed, it seems like it's kind of rare, but when it happens it's pretty disastrous unless you know just how to fix it.
    • Jun 12 2008 | 9:43 am
      In my experience the gremlins are simple typos... usually hitting the Ctrl modifier instead of Shift (or sometimes Option here in MacLand).
      The case where this first bit me was conversion of a Max 4 help file that had happily been carrying around a Ctrl-D since about 2001.
      TextWrangler has a nice "Zap Gremlins…" command which is helpful for this problem. Sorry, I don't know of a Windows util that does this.
      My guess is that any Ctrl char is evil except for tab/CR/LF. But that's just a guess.
    • Mar 07 2011 | 9:00 pm
      Not a clue where to start or what to do with this error, bump
    • Mar 07 2011 | 11:40 pm
      the latest version of Max is a start, I think they worked out some of these problems. Other than that, I'm not sure... find any gremlins as discussed above?
    • Oct 08 2015 | 2:02 pm
      Great info! I have same problem occured in my Win 32bit Max 7.0.6.......
    • Sep 17 2017 | 7:50 pm
      A new victim in town . Any easy solution before i start to really mess everything up ?