Failed attempts to control Cuemix FX via OSC

    Sep 11 2013 | 11:12 am
    I tried to get Cuemix controlled via osc, as it is possible to do that with TouchOSC, I thought it should work easily. But it doesn't...
    Thats what I tried: First I analyzed the osc messages from the Motu cuemix touchosc template. TouchOsc is sending for example this message for the first slider:
    /bin/fvEB+0/fvInCS+0/cdf 0.497549
    I connected TouchOSC to Cuemix, and TouchOSC is telling me its sending on port 53497.
    Then I tried to send the above message to the ip of my Macbook (code at the end of the post) I also tried localhost and a broadcast But Cuemix does not move the slider...
    I have no idea why this is failing... There is also some kind of handshaking between TouchOSC and Cuemix happening. But I don't know what how it is happening there. TouchOSC does see Cuemix as Host, but it does not see Max as host. The host is delivering the information about the ports to TouchOSC. In Cuemix I do see my iPad as TouchOSC device. I want to make it think my Maxpatch is a TouchOSC device as well... But how to achieve this...?
    Has anybody got a cuemix control of any kind working? (The HUI Protocol might be an option as well...)

    • Dec 27 2013 | 4:43 pm
      Hi Stefan,
      I am using Max to establish a OSC connection to CueMixFX and control volumes of all busses with a MIDI controller:
      If you want to dig deeper, you will have to check the OSC messages in the TouchOSC templates of the MOTU driver (see I have attached an example patch that uses osctools. Hope it works!
    • Dec 27 2013 | 5:12 pm
      Hey, This is very interesting for some motu devices owners :) thanks for the infos !
    • Feb 24 2014 | 10:57 pm
      Hey, i'm trying to dig into this at the moment, and can't understand several things... *i don't have touchOSC, apparently it's used because it has a built-in template for communicating with CueMix right ? this template that "sc7" at that motunation thread reverse engineered and which is there, is that it ? *so, one has to set CueMix in "OSC enabled" mode, but how ?... *on which channel does CueMix send osc informations ? Thanks, hoping someone will find it (i see dhjdhjdhj took part in that motunation conversation, maybe if he reads that... aaah, if only there was some kind of private messaging system...)
    • Feb 24 2014 | 11:23 pm
      Ok, so i just updated my motu softwares and voilà ! there is an osc enable option in cuemix fx (menu "control surfaces"). I should be going better now. Will report later if it works.
    • Feb 27 2014 | 11:30 pm
      What do the zeroconf objects do in Sarnold's patch ? i'm lost ! .. i can receive osc messages from CueMix, but had no luck sending any of them.
    • Feb 27 2014 | 11:33 pm
      i also don't understand what is meant by the "HACK NEEDED" paragraph..........
    • Mar 01 2014 | 1:25 am
      It works !....
    • Mar 03 2014 | 8:39 pm
      I just got a roughly working connection from my Fostex MixTAB Midi controler to the CueMix controlling a Motu UltraLite mkIII hybrid with the below project. For your own needs just replace the mtlin subpatcher with your own connection to your controller. This is far from being ready, not all potentiometers are connected yet, but (hopefully) you get the idea... The patch has to act as if it is a TouchOSC on an iPad. The feedback from CueMix only happens if CueMix assumes a specific view on the iPad. This is unnecessarily difficult, but MotU seems to think along "why easy if it could be complicated...;-)"
      have fun...
    • Mar 03 2014 | 9:23 pm
      hah, so that explains the necessity of the zeroconfs objects to declare as a "touchOSC like" device name ? btw i got it to work, modifiying Sarnold's patch ; i found it just right before the gig ;)
    • Nov 08 2014 | 3:55 pm
      Sorry to reply to such an old threat, but @VICHUG, could you please point me in the right direction of how you solved this?
      I installed the osctools, downloaded the patch of @Sarnold and changed the string "MOTU 828mk3 Hybrid CueMix FX OSC" to "MOTU 828mk3 FireWire CueMix FX OSC". There is no connection to CueMix FX at all. The status-light in the patch doesn't light up too.
      I'm struggling with the setup in CueMix FX itself too. I enabled the control surfaces but didn't add or edit anything in the OSC devices window.
    • Nov 09 2014 | 12:53 pm
      Hi everybody,
      it is somewhat difficult to figure out how the CueMix FX OSC interface works. This is a rough outline:
      1. CueMix is constantly looking for OSC clients that are announced via Zeroconf and have a name that ends with "(TouchOSC)". In my example this is Max on port 64711. 2. CueMix announces itself via Zeroconf with the name "MOTU 828mk3 Hybrid CueMix FX OSC on" or similar. If you have a different device, you have to change these two Strings to the matching device. Attach a print object to zeroconf.browser to find our your device string. 3. You may need to register your client in CueMix under "Control Surfaces"->"Configure OSC devices..." 4. IMPORTANT: my example patch relies on loadbang and loadmess objects. Please save it to disk and reload in order to start the connection.
      One more word about that strange HACK NEEDED paragraph:
      The CueMix client is not stateless. That means, you cannot control EQs and Faders (or different channel banks) at the same time, because you need to switch the mode to /mixes or /eq before these commands will work. The trick is to implement multiple OSC clients and use them simultaneously, e.g. one for the mix, the other for the EQ.
      I hope it will work like that for you. I've been playing over 50 live shows in the past months without a screen attached, using this connector without failure (except the usual MOTU firewire/USB driver hickups, but that's a different story).
      Best, Sebastian
    • Nov 09 2014 | 1:20 pm
      @Henny : aditionnally, depending on your OS, you might have a problem with your network configuration. I'm on Mac 10.6.8, and the connection wouldn't establish sometimes because a local networking service wasn't activated by default by OSX ; those cases were solved by creating an ad-hoc network via airport from my computer..; (even with nothign on the network). After discussing the subject on the irc of MacPort, this problem appeared to be very os specific apparently, and may or may not be solved with this. And i don't really understand it. IIRC there is a network observer tool on osx, and you can check from there if the address is there... don't remember which address it was (just "localhost" maybe ?), and my computer is beeing repaired now so can't help you more (*if* that were to be your problem). What is your Max window saying ?
    • Nov 15 2014 | 12:48 am
      Thank you very much for the replies guys! Unfortunately simply not working at all.
      Max window error for the zeroconf.browser is:
      zeroconf.service: unable to load object bundle executable
       2014-11-15 01:46:11.954 Max[7289:985210] Error loading /Applications/Max 6.1/Cycling '74/External/zeroconf.service.mxo/Contents/MacOS/zeroconf.service:  dlopen(/Applications/Max 6.1/Cycling '74/External/zeroconf.service.mxo/Contents/MacOS/zeroconf.service
       , 262): no suitable image found.  Did find:
       	/Applications/Max 6.1/Cycling '74/External/zeroconf.service.mxo/Contents/MacOS/zeroconf.service: no matching architecture in universal wrapper
      So the mxo's aren't loading properly thus not doing anything. I'm using ableton + max 64bit. Could it be that the mxo's are compiled for 32bit or couldnt that be the problem?
    • Nov 15 2014 | 10:20 pm
      that very much could be ! generally if an external is not said as beeing compiled for 64 bit/ was created before max 6.1 went out, it won't work in 64 bits.
    • Mar 17 2015 | 9:19 am
      Great thread for me. I haven't bought my AVB Ultralite yet, but I'm pretty sure I will. Both to use as mixer and interface live.
      I have some questions you might be able to answer. Will the OSC thing work over usb connection? I guess it should, but I don't like the term guess :) And I have a late 2011 macbook pro running lion osx. Will this be a problem?
      I should maybe ask the Motu guys this, but I like you guys better :)
    • Mar 17 2015 | 9:50 am
      About AVB on Mac… I just bought a nice CalDigit thunderbird 2 hub and discovered that its ethernet port doesn't support AVB (under OS X.9)! It seems to be Apple's driver fault: CalDigit relies on Apple's drivers, and some of their Ethernet drivers don't support AVB (in this case, the one for the intel i210 chip used in the hub). So be careful!
    • Mar 17 2015 | 11:13 am
      is avb the sccessor of the mk3 ?
    • Mar 17 2015 | 11:15 am
      @Patrick : it's written all over the AVB website that ethernet connection requires Yosemite. Apparently it's a "new" tech
    • Mar 17 2015 | 11:30 am
      AVB is supported under X.9 too. So, it is available on my new MacBook Pro, X.9 (with Apple's thunderbolt ethernet adapter), but not on my old 2009 iMac, X.9. You can see wether your hardware supports AVB if you go in the Network preferences -> Advanced -> Hardware. If AVB is supported, then you'll find there an AVB checkbox. Another way is to check if the "Network Device Browser" window in Audio-MIDI setup is available in the Window menu.
    • Mar 17 2015 | 12:27 pm
      So if my Network, Hardware tab looks like this (attached file), the ethernet lan connection will not work? Or do I need to upgrade to Yosemite to find out?
    • Mar 17 2015 | 1:14 pm
      @HZD : i suspect you should select the Ethernet tab before going into "advanced" (currently you're in wifi). I have no avb checkbox even though i have yosemite, plus if i go in audio/midi configurations ; the "Network Device Browser" is greyed out. Does it mean no AVB for me then ?
    • Mar 17 2015 | 1:34 pm
      @hzb - you need indeed to first select your Ethernet port, sorry I wasn't clear enough. Anyway, I don't think OSX Lion does support AVB.
      @vichug - some hardware supports AVB (then you also need to have a driver that supports AVB) and some don't. In your case I doubt you can get AVB with the ethernet port you use, but you could use another ethernet port (Apple's TB Ethernet adapter does support AVB, Apple's USB Ethernet doesn't)
    • Mar 17 2015 | 1:49 pm
      oh, okay. My mac is pre thunderbolt so...
    • Apr 22 2015 | 9:46 pm
      So, looks like my early 2011 macbook pro (now running yosemite) is compatible with AVB. So far so good.
      I have now managed to make your max patch say I'm connected to my UltraLite AVB. But I'm not getting any data sent to the MOTU.
      The udpsend localhost should be port 55000? Or do I need to find this via the bonjour browser? The sprint object seta a name for the receiving device. What doest the %s expect, so to say?
      Sorry if I'm asking strange questions, but I feel I'm getting close, so I'm very excited :)
      thx so far
    • Sep 08 2015 | 8:21 am
      Hi everyone, Resurrecting this thread from the dead is for asking if you have trouble with zeroconf and Yosemite : here, it's crashing constantly. I suppose the protocol may have changed a bit since the external was created...
    • Sep 19 2015 | 3:00 pm
      Thanks Sebastian, that's exactly what I was looking for :)
    • May 25 2018 | 1:51 am
      Hello Resurrecting this thread from the dead again. I'm trying to control my cueMix with a Traveler mk3. I use the patch from Sebastian here above. First, I did not succeed to build a 64bits of zeroconf and did not find any other external doing this. So I'm using Max in 32bits mode for the moment. I'm not able to control MUTE. Then, finally succeeded to control cueMix but after few minutes, Max starts to be very slow for some reason. Anyone has succeeded to do this with more recent system?
    • May 30 2018 | 12:38 pm
      Zeroconf crashes after a little time. I did a build of it in 64 bits and I got the same problem. Now I'm using java objects but the class OscService doesn't work on 32 bits. Does anyone know how to modify that class to work on 64 bits? I know nothing about Java.
    • Mar 08 2020 | 3:11 am
      resurrecting yet again and again this old thread, even though now it must've been digested by the worms ; the "zero" package has superseeded "zeroconf" and it should work as a near drop-in replacement and works no problem on 64 bits max. even though when i try to connect to CueMix now, i get a "bind to port 56887 unsuccessful, there is probably something already bound to this port" but maybe i'll find out something is already bound to this port.