"FFT bin index" doesn't show.


    Jan 14 2011 | 4:17 pm
    I'm tried FFT analyze with pfft~.
    But in the sub-patch,FFT bin index number doesn't appear from the 3rd outlet of the fftin~.
    The patch is not complex system.It's nearly basic FFT patch.
    What's bringing about?
    Please,give me the solution.
    [attachment=151280,1666] [attachment=151280,1667]

    • Jan 15 2011 | 1:35 am
      the index bin should appear from the right outlet of [fftin~]
      you could use the [count~] object instead.
      Could you show the whole pfft~ patch so it is easier to find a solution?
      i see you connect the fftin~ outlet of the bin index, first to a [number~]. i think that the [number~] when used at the "~" state, does not send out the received values, so there migt be your problem. bypass it and see if it works!
      Nikolas
    • Jan 15 2011 | 4:57 pm
      Thank you,Nikolas.
      I tried to bypass the [number~],but it doesn't go well.
      And I show the pfft~ patch again.(it's still under construct)
      The "top [number~]","second [number~]",and "[float box] under the [snapshot~]",all objects are showing "0.".
      It means that 3rd outlet of fftin~ doesn't put out any signal?
      Or I'm misunderstanding something?
    • Jan 15 2011 | 5:02 pm
      the pfft~ patch:
      [attachment=151345,1675]