forum software: when editing an previous post, greater/less than are removed

    Jun 06 2013 | 11:34 am
    I jut experienced this issue. I had written a post reply. It contain text with no formatting. I did enter some text like and but did nothing special with it.
    When I went back to the post and clicked the edit button to add a little more to my reply, the visual editor appeared but the QUERY and NODE text was purged. I had to re-enter it.

    • Jun 07 2013 | 5:05 pm
      Hey @diablodale. I'm looking into this now. I think the trouble is that the editor thinks those items are HTML tags and removes them automatically if it doesn't understand. The best really is to contain them in code tags.
      FYI, but we've simplified the editors and added a formatting guide below. I'd be happy to know your thoughts and if you have other suggestions.
    • Jun 07 2013 | 7:20 pm
      This is a test post of me typing into the new editor. I see no visual and text tabs to switch modes. I see no way to preview it. So this is a live test and comment at the same time.
      On the top I see some buttons like a b, probably for bold. As I just now clicked that, it inserted the html style tags for bolding. I am not able to visually see the bolding.
      Now I am going to try the button with a line through the letters del. That is an odd button. On the toolbar, it looks like it would be a strikethrough button. But when I clicked it in the last sentence, it inserted a DEL tag with an attribute called datetime.
      The ins button is putting an INS tag with also a datetime attribute. I am guessing these are some tools which can show deleting and inserting text. This seems, to me, a hyper-advanced Word revision marks...and would likely not be used that often in a manual way. I could imagine the server doing it automatically, like Word does, but its not a feature I think the forum needs.
      The IMG button prompted me to enter in an URL image and description for it. I entered a URL which is valid by spec, but an URL that has no image at the given location. I wonder how the new forum software will handle that. It could be helpful for the URL of an image to be checked at the end of the image prompts and before inserting the html tag for it.
      There are three buttons which deal with lists: UL OL and LI. As currently implemented, it requires a writer to know that you have to open a UL or OL before an LI and then close them in nested order. I see that the editor is keeping some state because it changes an opened tag to the needed closing tag. Perhaps You can assist writers such that the LI cannot be clicked until an UL or OL is clicked. And once of of them is clicked, its other (UL->OL) or (OL->UL) is unclickable...and...the LI becomes clickable. As it is now, its easy to get scrambled because there is no visual/preview and requires you to know HTML coding.
      The code button opens and closes a CODE tag.
      What is the morebutton?
      And then there is a lookup button. For me, this is clutter. It does nothing for the post text. Instead, it pops open a new browser tab to an answer site. I'm very comfortable that people that use browsers and visit the cycling74 site are able to open their own tab and use google or the search engine of their choice.
      Finally, there is the close tags button. It didn't do anything for me. I'm going to guess that if there are open LI, bold, or other tags, that it will close them at the current location.
      I clicked on the formatting guide under the text area. I see that it demonstrates how to insert a max patch. As a focus group of am 100% sure that I will never remove the PRE and CODE tags which are automatically surrounding the patch when copy/paste from Max itself. I am interested to see if the forum software handles/removes them. Here is a tiny patch.
    • Jun 07 2013 | 7:24 pm
      I see many failures. The following had no affect on the text and to me seems errant behavior - DEL did nothing - INS did nothing - IMG did nothing - CODE did nothing - MORE did nothing
      What did work: - BOLD worked
      What partially worked: - inserting a patch was successful. However, the surrounding CODE tags are visible.
    • Jun 07 2013 | 8:02 pm
      Thanks for doing all that testing! :)
      Hm. I guess it's tough to walk users through it, but I'm guessing those were failing because the tags were not closed when they were used. The buttons should change, indicating they need to be closed by having a "/" on them. Clicking on them again will automatically add the closing tag.
      Code tag if needs closing:
      DEL is indeed to do a strikethrough, to delete a section:strike
      INS is used in conjunction to insert a new section (to indicate a replacement of the one deleted):new content
      new content
      So a sample use would be something like: The weather today sucks, no, really sucks.
      This is why there is a datetime attribute, to show when the content has changed.
      The IMG tag should have embedded an IMG URL like so, but I see your point in that it should validate the img before it publishes anything:
    • Jun 07 2013 | 8:27 pm
      I thought I closed all my tags. I'll try again the del tag and the insert button to see if they work here.
      A more here tag is drectly after this before that.
      This is another try at the img tag the tag is before the "the".
      And here is an example of the code tag it should be right now is it working now?
      And finally, another patch just in case that caused all the problems before
    • Jun 07 2013 | 8:28 pm
      Nope. everything continues to fail as I originally reported. Not working for me.
    • Jun 07 2013 | 10:18 pm
      After some thought, I think it is best to just remove those crazy buttons. Do you agree?
      Please try the code tag again, though.
    • Jun 08 2013 | 11:22 am
      Yes, buttons like that lookup button are (to me) silly. I think its some legacy in the editor code...I vaguely remember seeing that in wordpress. OK, back on topic...
      I'm going to test the refined set of buttons in toolbar now. When I click the bold button I just closed the bold button.
      And now lets try the button that is slanted, the italic button and then close it.
      Hang on, its time to make a I typed this text after writing this paragraph. Argh, the link won't work if I leave it as is. I clicked that I wanted a link, it asked for the url and the title and then inserted it. But there needs to be text withing the A tags. Personally, I know how to fix it. But will less experienced users? Perhaps one approach is to help them. If a person has selected text and pressed link, then have it work as it does today. However, if they have not selected text and they press the link button, then take the title text they type in and insert that as the text between the A tags. They can replace it if they want. Its automatic for beginners and a way for others to know what to change. Just an idea. So after typing all that, I am now going to go up and put some text between the A tags above that don't have any yet.
      As I was typing, I was missing being able to press ctrl-b to get bold.
      Time for a blockquote. I've not tried one with the recent forum software. I'm guessing I need to put it on a newline.
      Ah, it made a newline automatically for me. So this is now within a blockquote. I'll type a little more so I can get several lines of it. Sidebar: I like coffee. I mean really like coffee. I was in Seattle for 13 years and we're all coffee addicts up there. If you ever visit Seattle, have a simple espresso or a latte at the Vivace Coffee stand on Broadway. Do it at the stand, not the inside cafe. Long story short -- the espresso will blow your mind; the latte won't even taste like coffee. The latter is like liquid manna.
      That ended the blockquote. I'm curious to see how it looks. Oh, its time for some lists. In text editor like this, I find its usually a mess. I have more success using a visual editor or just editing the html manually. Here goes:
      • I think it requires a lot of html knowledge to know how to use the UL OL and LI.
      • A user has to know to start/stop the LI for each entry in the list. The toolbar doesn't really help that terribly much
      • E.g., when I open an LI the closing UL should not be clickable.
      • and the OL should not be clickable. (yes, technically its possible with html but its likely a layout/support/testing nightmare
      OK. That was my unordered list. Now for some order in life:
      1. There is no better coffee in the world that at the sidewalk Vivace Espresso in Seattle
      2. Any talk of Blue Bottle in SFO is heresy
      3. Berlin is not a coffee city...Deutschland is not. I hear the tea is nice. sigh inside nested bold and italics
      That was hard! At the end of that last line, I had to carefully press 4 buttons in exact order to close everything correctly. the close for EM STRONG LI and finally OL. Yikes.
      Now a test for the code button beep beep 1 2 3 that should have been code.
      And now a little patch:
    • Jun 08 2013 | 11:30 am
      The CODE isn't rendering. I click the button and it puts in the html, but when the post is submitted and rendered the text isn't code-ified. In addition, I visually see the CODE tags around the inserted patch.
      I am going to attach the text that was in the editor before I pressed submit. I selected all and then copy/paste into notepad. You can see that the CODE tags are in that last sentence, but they don't render. As I look at the actual page's html, the CODE tags have been stripped out. This in contrast to the CODE tags around the patch which were changed into entities.
    • Jun 11 2013 | 12:26 am
      Cool. We're working on the Max patch paster to strip those tags upon pasting. Stay tuned for updates on that.
    • Nov 08 2013 | 6:06 am
      what's wrong with this????