[Found] Get input from Axis IP Cameras in Max + using other IP Camera question

    Aug 21 2013 | 10:03 am
    I just found out about this app: IPCAM2SYPHON https://github.com/bakercp/IPCAM2SYPHON
    You just get the app from https://github.com/bakercp/IPCAM2SYPHON/downloads . It comes with 15 streams ready for testing. And the output gets relayed to Max via Syphon. But you can start playing (by editing it) with the streams.xml file that comes with the app.
    For anyone wanting to play, just go ahead.
    My problem is I cannot use my camera which is not an Axis camera with IPCAM2SYPHON. It is a wireless camera which comes with its own Access Point. With an IP Camera application (EvoCam in my case), I just connect to it by setting its ip and port (http://[IPADDRESS]:[PORT]) and path (/video.cgi) Username and Password and it just works. I set up my camera and another camera for testing purposes. See image_1.png to see that they both output images.
    Now in IPCAM2SYPHON (see image_2.png), I see that the app receives bytes from the camera but it does not show any images. The test camera outputs images just fine. This is the simplified (only 2 cameras, mine and one for testing purposes) streams.xml file I am using (I edited out otherwise the forum does not let me paste them):
    window x="100" y="100" width="1024" height="768" rows="1" cols="2" videoDisplayWidth="320" videoDisplayHeight="240" disableRendering="0" showStats="1" logger level="VERBOSE"/
    stream address="" name="ipcam0" username="hot" password="hot" display="1"/
    stream address=" resolution=640x480" name="ipcam1" username="" password="" display="1"/
    Any ideas? Thank you for looking into this

    • Sep 06 2013 | 2:52 pm
      Thanks so much for this! I think this may just work for what i need...and seems pretty stable. now to find some webcams that include sound as well!
    • Nov 19 2013 | 11:53 pm
      Yes, this is also exactly what I needed... Perfect! :)
    • Jul 28 2015 | 3:10 pm
      Hi ygreq Did you ever solve your problem? I'm trying something similar and checked different ways to get a h264 rtsp-stream into max without success. I would appreciate any help!
    • Sep 16 2015 | 3:13 pm
      Hi all,
      Has anyone had luck getting rtsp into Max from IP cams, either with IPCAM2SYPHON or just into jit.movie?
      My feed works in VLC, but not in Safari or QuickTime: I get an error that QuickTime can't open it, perhaps because of things dropping rtsp support lately.
      With jit.movie, I get a QuickTime logo with animated progress bar but no more.
      With IPCAM2SYPHON, I can get the default streams into Max (but only one at a time), but they're all http, not rtsp.
      Any relevant success on your end?
    • Sep 20 2015 | 10:07 am
      Hi Jeff I have the same problem. For now I just open the stream with vlc and use jit.desktop to grab it. But that's an anoying workaround... so if you find a way to bring it directly into max, please post it here. greetings
    • Sep 20 2015 | 1:45 pm
      So far, my "workaround" was to stumble upon the right URL to get http streaming from my camera. I found several different versions and none of them worked until I tried using one URL if found and changing the channel number in it. So the URL that worked for me was different from every other one I found :?/