Funky scheduler timing, 5.08, OSX 10.6


    Oct 02 2009 | 8:05 am
    I did a quick search to see if someone else hasn't reported this yet, but if I missed it, apologies to all.
    With overdrive on, even extremely simple patches give me terrible timing issues. (See the self-explanatory screen grabs.) Essentially, [timer] reports [metro 200] intervals of 200 ms while [cpuclock] measures around 440 ms, with overdrive and msp on. (cpuclock is right.)
    DSP settings:
    Driver: CoreAudio EDIROL FA-101
    I/O Vector size: 512
    Signal Vector Size: 64
    SR: 44100
    Scheduler in overdrive: check
    Audio interupt: check
    Vector optimization: check
    Note that settings audio driver to built-in output solves the problem, as does setting scheduler off the overdrive or the audio interupt.

    • Oct 02 2009 | 12:00 pm
      In the same vein, I'd like to report that I had a puzzling experience recently with clocker set to a constant 100msec interval producing values such as 0, 100, 200 etc. After simply unlocking and re-locking the parent patcher the values jumped to an offset, e.g. 440, 540, 640. This was on Leopard and Max 5.0.8 with Overdrive turned off. My experience from Max 4.6 is that the clocker intervals don't change even when the scheduler gets backlogged.
      Georg