gen~ au export cannot open component: -1

    Jul 14 2013 | 1:18 pm
    I tried to build a very simple gen patch as in this post I managed to export it as an audio unit plugin in xcode without errors but with lots of warnings. When I try to auval -a in terminal I get "cannot open component: -1" Does anybody have any idea how to move on here? I'm on Max 6.1.3, xcode 4.6.3, I use‎, I use the Audio Tools for Xcode from February 16.

    • Jul 15 2013 | 9:27 am
      The warnings should be ignored. My version are the same. Can you load it in a vst~? When through all folders in the project do you see any unlinked (red) items?
    • Jul 15 2013 | 4:53 pm
      Does the AU component look like the others? Inside the component package in Contents/MacOS, does it have an executable? Did you change the identifier constants in the .r file?
    • Jul 15 2013 | 7:33 pm
      The AU component looks like the others except that there is a blue w on one of the sides of the others. My AU component is a totally white LEGO brick. It has an executable in the package Contents/MacOS with the same name as the component. Anyways, just checked it all again and it was solved by only having three characters in the COMP_MANUF constant in the .r file and in the manufacturer string in the .plist file.
      As for the VST, I have not got that to work. I had to relink the files in the vst2.x folder in the Xcode project. When I build the project I get this error: Clang LLVM 1.0 Error
    • Jul 16 2013 | 5:26 pm
      In the left-hand column in xcode, there's a list of icons with different views. Open one on the right called "Log Navigator" and click on the top item to show the build errors. In there, you can expand the log listings to show more details on how the commands failed. Anything useful in there? From what you provide, I can't really speculate as to what might be happening.
    • Jul 17 2013 | 9:04 pm
      By looking at the logs I figured out that the issue had something to do with the path of some of the source files. Specifically the ones located in vstsdk2.4/public.sdk/source/vst2.x/ - these were actually the files I relinked as the xcode project couldn't find them. Even though everything looked right, in the error log I could see that the were expected to be in vstsdk2.4/public.sdk/samples/MyPluginName/MyPluginName/vst2.x/ (where my project is located in vstsdk2.4/public.sdk/samples/MyPluginName/)
      Now everything seems to work for both AU and VST. Thanks a lot for your help.
    • Jul 18 2013 | 2:34 am
      Wonderful! Glad it's all worked out.
    • Jul 30 2013 | 6:07 pm
      I have the same "Cannot open component: -1" on auval -a at terminal. I updated max to 6.1.3 and triple-checked the .r file and the .plist file , here it is:
      #include #include "BiquadConstants.h"
      #define RES_ID 1000 #define COMP_TYPE 'aufx' #define COMP_SUBTYPE 'BIQD' #define COMP_MANUF 'VAVD' #define VERSION Biquad_VERSION
      // To work correctly with the generic view, the value for NAME must follow a specific pattern: // : #define NAME "Vavdo: Biquad Plugin" #define DESCRIPTION "description" #define ENTRY_POINT "BiquadPluginEntry"
      #include "AUResources.r"
      The output file is 716kb, it has exec at Biquad.component/Contents/MacOS and seems to be as any other on components folder.
      Is there anything else that I can check? I cant find any documendation on this type of error..
    • Jul 30 2013 | 7:39 pm
      Hi KAROLOSG,
      I solved this issue by only having three characters in the COMP_MANUF in the .r file the same in .plist file under manufacturer. Hope this works for you as well.
    • Aug 01 2013 | 11:03 am
      Hey Soren, Thanks for your quick reply, but unfortunatly it couldn't help. The only way it seems to be working is to write total different COMP_MANUF and NAME in the.r file. Then I have two instanses in the auval -a validation. The one is working and the other is not (with the same "Cannot open component: -1". But opening it on Logic I cant get any sound(with a simple gain gen~ patch) Is there any instructions on 32 or 64 bit exportcode-xcode compile?? I have a suspition that this is the fault...