Getting started with Max MSP 5.1.7 and Windows (VS C++ 2010 or Cygwin) externals

    Mar 26 2012 | 5:40 pm
    Hi all, I have tried to find out, how to set up a development environment under windows 7 (64bit) for coding an external for Max/MSP.
    Under MS Visual Studio C++ 2010 Express I'm not able to compile the code because of problems with the linked header files from the max-includes.
    1>c:transfermaxsdk-5.1.7maxsdk-5.1.7c74supportmax-includesext_prefix.h(73): warning C4068: unknown pragma 1>c:transfermaxsdk-5.1.7maxsdk-5.1.7c74supportmax-includesext_prefix.h(106): fatal error C1083: Cannot open include file: 'MacTypes.h': No such file or directory
    So I tried to set up the cygwin development environment. Here I have the problem, that I cannot build with the -mno-cygwin flag. This is a known problem. The information I have found in the MaxSDK-5.1.7examplescollectCompilingWithGCC.txt and regarding this issue is not helping me either, because I do not know how to install the "Automated Mingw installer (MinGW 5.1.6)" or the "MSYS-1.0.11.exe" My attempt to get Eclipse up and running failed to. I have problems to tell Eclipse how to link the header-files. fatal error: ext.h: no such file or directory Event though the corresponding "ext.h" file can be found navigating the "includes" in my project. (can be seen in the attached Screenshot)
    Does anybody has a development environment under Windows 7 (Windows 8) 64bit running? What are the steps to bring it up and running?
    Thanks in advance! All help and hints are welcome

    • Mar 26 2012 | 10:48 pm
      Finally I found a solution for setting up the development plattform for working on externals: Eclipse IDE for C/C++ Developers with Eclipse CDT and cygwin. There were a lot of trouble regarding the paths for the includes and libs - but finally most is working.
      So I'm able to compile the first files from the Max/MSP SDK. But I still have troubles to compile a CPP-File, which I should take care of.
      The error message is: fatal error: MacTypes.h: No such file or directory external location: C:cygwinc74supportmax-includesext_prefix.h
      and there are a lot of messages regarding Symbol 'NULL' could not be resolved like in this line: x->c_outlet = outlet_new(x, NULL); or in this line: if(x->sftp == NULL){
      and, like in the Visual Studio, I have the warning regarding "#pragma d0_pointers" from line 73, external location: C:cygwinc74supportmax-includesext_prefix.h (which is an error in Visual Studio)
      any hints?
    • Mar 28 2012 | 5:57 am
      Hi Vanille, thanks for your hint. I'll try to remove "MaxLua.framework". How can i set the WIN_VERSION flag?
    • Apr 15 2012 | 5:16 pm
      Hi, I'm using visual studio 2010 on windows 7. You have to create your externals projects in the same folder of the examples or to keep the same path to the max library. ex : MaxSDK-5.1.7myObjectsObject1Object1.vcproj
      It should work.
    • May 01 2012 | 6:37 pm
      Have you looked at the files in the 'collect' example in the Max 6 SDK? There is some info in there about compiling with Cygwin.
      Cheers, Tim