Getting started with Max6 SDK & XCode 4.3.1


    Mar 19 2012 | 12:08 am
    Hi mates, I'm trying to test some examples build.. driving into strange errors.
    I tried to compile for 10.6 sdk or 10.7, all the same. I didn't move anything (folders etc I mean)
    On the snapshot, we can see permission denied... So, I suspect this : XCode 4.3.1 is installed basically into /Applications and I don't have any /Developer folder BUT an /Applications/Xcode.app/Contents/Developer/ folder.
    Btw, I have no problem with Open Frameworks compilation I'm currently making all the day.
    In case of, I used (for the first time) xcode-select: sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer/
    It hasn't change anything... still errors.
    I have some dsp codes I designed for iOS purposes (but pure c++) and I'd like to create max externals :-(
    Anyone ?

    • Mar 22 2012 | 7:58 am
      Hello
      I've got the same issue, did you find a way to solve it?
      Pierre
    • Mar 22 2012 | 8:03 am
      I still didn't. I had some answers in another thread as if I was the only one to have this issue so I guessed it was a problem of configuration of my, however, very standard mac OSX and last XCode version working well with everything else.
      so.. no. No solution yet.
    • Mar 22 2012 | 9:58 am
      problem solved I've changed some stuff in maxmspsdk.cconfig and it builds!
      I can give you more details or a copy of my maxmspsdk.cconfig if you want
      I use Lion with xcode 4.3.2
      Pierre
    • Mar 22 2012 | 10:18 am
      yep it could be interesting I, myself, made some changes but I didn't yet solve it
    • Mar 22 2012 | 11:11 am
      Voila
      hope it helps you
      regards
      Pierre
    • Mar 22 2012 | 12:03 pm
      it bugs again, but i've finally switch the base sdk to lastest MAC OS X (10.7) and
      SDKROOT = /Developer/SDKs/MacOSX10.7.sdk MACOSX_DEPLOYMENT_TARGET = 10.7
      in the maxmspsdk.xcconfig
      and it works... for now
      Pierre
    • Mar 22 2012 | 12:59 pm
      The SDK, if you have XCode 4.3.1 (and only this one) isn't placed in that folder.
    • Mar 22 2012 | 1:15 pm
      after severals test it appears that i can't compile under 64 bit architecture, I have to switch it to 32-bit intel in the build settings
    • Mar 22 2012 | 2:50 pm
      the exact path seems to be /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs
      in xcode 4.3.2 ( today update!)
      i've got only one version of xcode installed
    • Mar 22 2012 | 3:45 pm
      indeed, XCode is now a legacy package.