getting two jit.window to go fullscreen on two projectors on startup


    Feb 23 2011 | 5:17 pm
    Hey Hey hey
    I am creating a touch screen installation using Max/Msp. When I execute the patch I the two jit.windows to go fullscreen on 2 projectors while having the interface on another screen.
    How do i get the jit.windows to start fullscreen automatically on each projectors?
    Another question: What kind of hardware setup would you guys suggest?
    Best regards Mikkel

    • Feb 23 2011 | 8:48 pm
      Ypu should use a matrox dual head to go for your two projectors. In jitter all you have to do is to tell jit.window the position and the size of the two other screen. Check this simple patch :
      Pierre
    • Jan 02 2017 | 6:17 pm
      hi pierre and everyone, i find this is super helpful, and very glad it has been shared. i would love to use it for a 2 projector setup, as well, but somehow fail to implement it in my patch. how are the 'sel 0 1' objects triggered? tried to use a button, but... sorry for the stupid question
    • Jan 03 2017 | 7:47 pm
      check out the jit.displays object which will allow you to query the coordinates of all connected displays, and use those for the @rect attribute of jit.window / jit.world
    • Jan 04 2017 | 9:32 pm
      works, thank you so much!
    • Mar 16 2017 | 7:38 am
      with this same patch i got a problem now. i'm using a HDMI now, and the positions that are read for both projectors are exactly the same now - and they don't get extended to the projectors at all anymore. i don't know where my mistake lies, but have to test & perform tonight & tomorrow :( any help highly appreciated
    • Mar 20 2017 | 7:51 pm
      do you have mirroring enabled in your display preferences? you should also disable "Displays have Separate Spaces" in the Mission control system prefs (if on a Mac)
    • Mar 20 2017 | 8:04 pm
      use Pwindow, make patcher window size to range across both screens.
    • Mar 24 2017 | 5:25 pm
      @rob: thanks for your response again, both options seem to be active - really no idea where the change is. have updated to sierra meanwhile, prob not a good idea, no change either (so far), just an info :))
      @roman: really nice idea for a workaround, will test :)
    • Mar 24 2017 | 5:34 pm
      both mirroring and "displays have separate spaces" should be disabled, not enabled.
    • Mar 25 2017 | 9:24 pm
      hahaha, nice misunderstanding with almost comic character. thanks for your guidance, rob, it works now - no idea why settings switched back with cable upgrade. need to do quite some homework, i guess