(good) software to make/convert .obj files for jit.gl.model???

    Jan 02 2011 | 1:43 pm
    1 searched the forum and internet 2 installed latest versions from Wings3D, SketchUp and Blender 3 have maked simpel objects and exported to .obj 4 but never possible to read in jit.gl.model without problems???
    Mostly nothing happens and sometimes i get "out of memory" error. I have installed the latest "Incremental Object Updates" jit.gl.model.
    I know this: ".obj Model File Compatibility There are many extensions to the basic .obj file format in existence. Some of these are NURBS and parametric surfaces. Right now, only vertices, polygons, groups, materials and texture coordinates are supported."
    Some .obj files that have worked before Max 5 do also not work anymore.
    Why does this have to be so hard and time consuming?
    Is there somewhere out there software that can convert/export "special" Jitter .obj's that work direct with jit.gl.model?
    Can somebody tell me the "good" steps to follow?

    • Jan 02 2011 | 1:56 pm
      I like AccuTrans 3D, it looks like 1985 but it works fine. I had crashes with some .obj files, something about not having a group defined. Perhaps this has been fixed with the update.
      Be sure your material files are there, or better yet, don't use any materials at all.
    • Jan 02 2011 | 2:43 pm
      AccuTrans 3D looks really '80's :), but i am on Mac. I don't use materials for the .obj files.
    • Jan 02 2011 | 3:37 pm
      I use Cheetah3d, it's not free, but inexpensive for the kind of app it is. It also exports groups and materials, something I found was not always the case (with LightWave e.g.)
    • Jan 06 2011 | 5:21 pm
      Ok, thanks. I will try that one also. Does anyone know how to properly export .obj files from SketchUp Pro? I have tried every possible .obj setting but no change to get it working with [jit.gl.model].
      What i want is really simple: Convert illustrator file to .obj file that i can use with [jit.gl.model]. I am on Mac. But this seams so difficult that i still can't believe it. All help is usefull. Thanks.
    • Jan 06 2011 | 8:51 pm
      i am interested looking at your obj files that are not loading with jit.gl.model, as we are working on improving this object for future versions of jitter. please post here, or email to ramirez _at_ cycling74.com
      please keep in mind that only polygons are currently supported (no nurbs,curves, etc).
    • Jan 06 2011 | 9:49 pm
      Hi only polygons? in the tutorials is written: "... Right now, only vertices, polygons, groups, materials and texture coordinates are supported." So it isn't possible to import .obj's that only exist out of a (out)line?
      So "no curves" is my problem i think? What does this "out of memory" error means?
      Here in attachment a .zip file with two SketchUp test .obj exports: - SketchUp_men.obj => i have get this working with [jit.gl.model] - SketchUp_circle_edges.obj => doesn't work but the code inside the file seams identically.
      I need the ability to convert and use illustrator vector "lines" (that i already have constructed) in Jitter. So what i try to do for now is: Illustrator > export > .dxf (ACAD file) > import > SketchUp > export > .OBJ
      Will there in the future come more import/read possibilities? .dxf or .dwg import/read?
    • Jan 06 2011 | 10:06 pm
      i should say triangles are the only supported geometry, no curves or nurbs. you can output a matrix of vertices using @matrixoutput, and do whatever you want with them. eg, you can iterate the matrix, and send them to gl.sketch's stroke drawing messages.
      i have no problem loading either of the two files you've provided with jit.gl.model.
    • Jan 06 2011 | 10:12 pm
      Yes, i am already using @matrixoutput.
      Can you see the simple test circle when you load "SketchUp_circle_edges.obj"? I get an "out of memory" error.
      So what is the problem that i have? How can i fix that?
      Like i have already mentioned; i have installed the latest "Incremental Object Updates" jit.gl.model.
    • Jan 16 2011 | 6:05 pm
      Here i'm back. Now i can get it anymore. When i load "SketchUp_circle_edges.obj" in jit.gl.model that works for you i get always the "out of memory" or "not an object" error. I have done tests on two different computers this:
      MacBook Pro - Intel Core 2 Duo - 2.5GHz - 2GB SDRAM Graphic Card: NVIDIA GeForce 8600M GT - 512MB VRAM # MaxMSP 5.1.3 Jitter 1.7.0 with the latest "Incremental Object Updates" jit.gl.model. ==> "out of memory" error # MaxMSPJitter 5.1.7 DEMO ==> "out of memory" error
      Powerbook G4 1.5GHz # My old MaxMSPJitter 4.6.3 on my old laptop ==> "not an object" error
      But this test "SketchUp_circle_edges.obj" file works for you Robert.
      Can somebody tell me what "out of memory" error in this situation means? It can't be a real "out of memory" error because when i load the somewhat "more" complex .obj files in the Max5 > patches > media > models folders i don't get an error at all.
    • Jan 17 2011 | 4:31 am
      Tested here on a MacBook Pro 2.4Ghz :
      - SketchUp_men.obj => works fine - SketchUp_circle_edges.obj => instant crash