grabbing 1080p/29.97 on Mac - impossible??

    Feb 03 2014 | 3:20 am
    Hi, I have a camera that puts out 1080p at 29.97 (or 25) fps, over SDI. I got a Blackmagic Mini Recorder to grab it with. In jit.qt.grab, I can select the "Blackmagic HD 1080" device, but the input list only shows 1080p 23.976 or 24; or 1080i 59.94 etc. - no 1080p/29.97. I even tried with the new qtkit grabber. Same thing happens if I try to capture in Final Cut 7. But if I use Blackmagic Media Express, it works.
    I asked Blackmagic tech support, and they said:
    Final Cut Pro 7 uses a legacy version of QuickTime that was developed before those formats were supported by our hardware. Third party softwares that use a more recent version of QuickTime should be able to access these format with no problems. As we do not include support for applications such as Max/MSP in our drivers I would recommend checking that they do support our cards and are compatible."
    I guess "a more recent version of QuickTime" means AVFoundation? Which is not supported in Jitter? Is it actually not possible for Blackmagic to support 1080p/29.97 capture for "old fashioned" QuickTime, or are they just not interested, and some other company's capture device could work?
    I'd much appreciate a solution to get this video into Jitter. Different hardware, some other Blackmagic-enabled Jitter object, maybe another application (free?) that could grab and send via syphon?

    • Feb 03 2014 | 4:19 am
      Try capturing with the 59.94i setting. 59.94 refers to the field rate, its frame rate is actually 29.97.
      Whatever you capture will be tagged as interlaced, which could affect downconversion later.
    • Feb 03 2014 | 2:53 pm
      Thanks for the suggestion, but I tried that already and it doesn't work. The picture is just black, in both Jitter and Final Cut, if I use the 1080i/59.94 input setting.
    • Feb 03 2014 | 5:39 pm
      Blackmagic's support is fairly bad so most of what you try is unfortunately going to have to be holistic or outright voodoo. The mini recorder is a newer piece of thunderbolt hardware, so its ability to work with a rarer flavor of SDI video on legacy quicktime is going to be limited or nil.
      My recommendation would be to try out gear from a few other manufacturers (AJA, Matrox, MOTU) to see if you can get good out of the box compatibility with 30psf SDI streams.
      If that's not an option, you will need to experiment with all the different possible variables - including signal source, operating system, type of Blackmagic drivers, presence of a genlock source, etc. Good luck.
    • Feb 03 2014 | 10:18 pm
      It's the same with the Decklink Mini Recorder pci version too. Also, it's 1080p, not psf.
      Unfortunately the others (AJA, Matrox, MOTU) all seem to be about ten times the price, and I need three of them, so not really an option. But I'd be interested to know if anyone can confirm they work with Jitter and 1080p, just to know if it's Blackmagic being lazy and not updating their drivers for "obsolete" quicktime.
      I don't think there are any variables left that I haven't tried already. Seems I would need a Jitter grab object that specifically supports Blackmagic hardware. Whether that means using Blackmagic's SDK, or AVFoundation, I don't know. With all the people using Decklink hardware with Jitter, I would have thought such a thing existed already, but it seems not.
      In that case, it looks like the only option is some utility that can do the grabbing and send it to Jitter via Syphon. Surely something like that exists? All I can find are expensive VJ suites so far, Resolume, VDMX, etc.
    • Feb 04 2014 | 4:14 am
      What is the camera model? I can take a look at the manual.
    • Feb 04 2014 | 4:56 am
      I use the intensity black magic device and was getting similar black screen of death. Try using the jit.qt.grab helpfile first. You might need to use both the device list and input list to get the settings right, also make sure no applications are using your camera in the background. I noticed some weird stuff with the livestream application taking over my camera when its on.
    • Feb 04 2014 | 4:01 pm
      Thanks, but the camera's output is working fine. The problem is not a "black screen" per se. The problem is that Blackmagic's QuickTime driver doesn't offer 1080p/29.97 input as an option in Jitter (see screenshot below).
      Without that option, there's no way to get the video into Jitter. Using one of the other frame rate inputs just doesn't work.
      It's the same with Final Cut 7, and Blackmagic confirms that it doesn't work, and the solution is to capture with their Media Express application, or use Media Composer or Premiere, both of which specifically support Blackmagic hardware - I tested them, and they all work with my camera. Of course that doesn't help me get live video into Jitter.
      I'd be curious to know if anyone with Aja, Matrox, or MOTU hardware gets the option for 1080p/29.97 in Jitter. That would confirm that it's not a limitation of "legacy" QuickTime, but just that Blackmagic can't be bothered to update their driver. It's a moot point though, since either way I guess it won't happen.
      As far as I understand, Jitter would have to support Blackmagic hardware by using the SDK supplied by Blackmagic. Or, (maybe?) to use AVFoundation. As this point it doesn't look like that's happening anytime soon either. Would be a great project for someone to write a Blackmagic grab object for Jitter, using their SDK. Not only would it support all resolutions, but should give less latency and overhead. Unfortunately I don't think I'm up to it myself...
    • Feb 13 2014 | 8:52 am
      Hi all, I second your request to get the full list of resolution on my Blackmagic Intensity Express resolution in jit.qt.grab. Indeed, I'm trying to get a 1080p/30 or 1080p/25 and I'm not able to do it (those resolutions don't appear in the list). I also tested it with different BlackMagic device and it's always the same list.
      VDMX ( , Millumin ( or Blackmagic Media Express are able to grab it (see attached files).
      Can someone from Cycling'74 could tell us if it will be updated? I'm totally blocked in my current project due to that problem.
      Thanks in advance for your reply.
    • Feb 18 2014 | 7:53 am
      Hi, Does anyone from C74 has an answer to our request? Thanks. Have a good day. B.
    • Feb 23 2014 | 7:58 pm
      seems like the angels at vidvox heard your request:
    • Feb 24 2014 | 5:49 pm
      Thank you Rob, as VDMX user I was aware of it and it is definitly the best solution for now. I wish they implement a way to save the settings in a new version... But can you tell me why isn't it possible to do it all in max? Those interfaces are the most popular and affordable in the pro market... Thanks.
    • Feb 28 2014 | 12:38 am
      I am doing the same thing and would like to know how to go from black-syphon to max/msp?
    • Feb 28 2014 | 8:04 am
      Black syphon is using the syphon technology. In Jitter, you have to use the syphon objects bundle: An help file is included.
    • Mar 04 2014 | 8:05 pm
      Hey, that's great Rob, thanks to Vidvox for Black Syphon! Very useful for Jitter users.
      Benoit, it could be possible to do it all in Max, but it needs C74 (or someone else) to create a Jitter object using the Blackmagic SDK. If enough people ask for it, I guess they would do it.
      Or, maybe C74 is already busy converting Jitter to use the modern quicktime framework, AVFoundation, which would (in theory) also make it work. But that's a very big topic...