Granularized issue


    Dec 17 2009 | 12:17 am
    Hi, this is a patch-specific issue using Les & Zoax's "granularized" patch — which i've been using for years without a problem.
    It basically won't keep playing grains more than half a second after I turn the audio on. Switching "grains off" / "grains on" would not retrigger anything. thoug,h turning off / on the whole audio would make it play half a second and stop again. (it last exactly the same duration every time — rather around 300-400 ms actually) Neither the bang-triggered single grain, or the linear playback would respond at all.
    Though, if in the meantime, I create/delete msp objects in another patcher, or if I change the signal vector size, then it would retrigger some grains. (looks like a scheduling type of issue).
    the grains' play will last a bit longer if I slow down the grains triggering, but always ends up stopping in the end.
    Any help?
    [It really does not feel like any cpu issue and the machine has much power] No similar issue with all my other patches. I run Max 5.0.8 under 10.5.8 on Intel mac Pro.
    Thanks already if you read the whole story.. O.

    • Dec 17 2009 | 7:28 am
      It seems that it plays one grain and that the method for playing another grain is broken. What objects are used? Did this happen after an update of max?
      _ johan
    • Dec 17 2009 | 2:35 pm
      Just note that there are now 2 versions of this patch: the "old" Max 4 version has been updated in the examples to a Max 5 version. Don't know if that has anything to do with your problem, though.
    • Dec 17 2009 | 6:19 pm
      Thanks johan. It's playing several grains though, a whole bunch before crashing (rather stopping).
      I have a Max5 version, I guess it's the most recent version of this patch, i use it from the examples of the 5.0.8 max install. I did not update recently, and I used the max5 version many times without problem; I don't know what happened in the meantime.
      I wish Mr Les would have a clue..