graphics card stopped working - any ideas ?

    Jan 17 2009 | 2:07 am
    Dear List,
    My laptop's graphics card suddenly stopped working, all patches doing anything fancy in opengl just give me blank screens, the textures don't draw to planes. Even things that normally work like the opengl feedback in jitter recipes book 2 and vade's jitter movie optimization patches just give black screens. I seem to remember this happened once before and reinstalling the graphics card drivers seemed to help. I've removed and reinstalled the drivers and at the same time uninstalled max, trashed the preferences and reinstalled it but it doesn't help. I've tried the omega and the regular drivers for my card but it's still blank. Please chime in if this rings a bell and you have an idea what to do.
    Laptop = Acer 8104WLMi Travelmate GFX Card = ATI Mobility Radeon X700 Drivers = 8.163 / 4.8.442 (Omega)

    • Jan 17 2009 | 11:30 am
      what error messages do you get in system console
      "the textures don't draw to planes"
      so you still see the planes in grey or white? which could mean out of memory on vram...
    • Jan 17 2009 | 12:42 pm
      cheers for the reply mj, i see the planes in grey or white or checked in the opengl feedback jitter recipes 2 patch but no video texture. in my own rutt etra patch posted below it's just all black, i know it works ok on my desktop and it did work fine till recently on my laptop.
      annoying thing is i don't get any error messages in the console. stuck.
    • Jan 18 2009 | 12:05 am
      ah i ment in the system console window , but i see you're on windows. there must be somewhere a file with system messages. maybe... i dunno windows...
      try smaller movies/pictures for textures if that works its probaly a video-memory problem
    • Jan 25 2009 | 7:19 pm
      Hi MJ, everybody, openGL rendering calls work, I can draw platonic solids etc, but I still can't load textures to display on things (videoplane included). I've tried using jitter tutorial 34: using textures and the platonic solid just appears black when I tell it to use the picture texture.
      Nothing comes out on the max console just
      Jitter 1.7.0 installed building GL on window "mister"...
      I'm going to email tech support at my laptop manufacturers but my laptop is 3 years old so I doubt they'll care. Please help you're my only hope.
    • Jan 26 2009 | 12:42 pm
      I can't even get glView ( to work so I'm figuring this is something non max related. Stumped.
    • Jan 26 2009 | 1:21 pm
      when I try to run the glview rendering tests they fail with the following information
      ...Legacy PFD creation.: SetPixelFormat ID:5 failed: The operation completed successfully.
      Temporary context creation failed: The operation completed successfully. - 1680 x 1050, 32 (AAx0)
      ...DestroyWindow: ReleaseDC failed: Invalid device context (DC) handle.
      3dmark06 runs fine (albeit really slowly) and dxdiag works fine (it loads the texture for the cube) so directx seems to work. I've tried the omega drivers, the original and the updated drivers from my laptop manufacturer's website.
      My laptop is an Acer Travelmate 8104wmli
      The only thing I can think of now is reflashing the bios on the graphics card but I don't even know if that is possible on a laptop gfx card. I'm hoping someone more knowledgeable than me on this forum might be able to help.
    • Jan 26 2009 | 2:02 pm
      scratch that last post, it turns out glview won't work on x700s for glview versions higher than 2.33 because of a bug with ati's drivers. so I dl'd 2.33 and success I now have a floating cube with the opengl texture on it so I know some textures will load, just not ones from jitter (like i said even the tutorial 34 patch on textures won't work).
      glview tells me both fbo and pbuffers work, i tried uninstalling max/jitter trashing the prefs, reinstalling it and still no luck.
    • Jan 28 2009 | 4:25 pm
      After much messing about I wiped my hd and installed a backup of windows and my system partition I made a year ago. Seems to have fixed it. Probably some obscure annoying tiny registery entry, part of the joy of windows I guess. This thread is now officially about cats. I like tabbies.