~groove + ~buffer doesn't play sound

    Jul 14 2010 | 10:05 am
    This is driving me nuts:
    In my patch, playing audio with ~sfplay works fine, but with ~groove nothing happens. It's just dead. In a few cases I was able to play with no problems from within the ~groove help file. But even then if I copied the contents of the whole ~groove help patch to my own patch, suddenly it stopped working. Now it seems to not even work from within the ~groove help patch anymore. ~sfplay still plays fine in my own patch, so I assume that nothing is wrong with my DSP settings.
    What could be wrong? Why has ~groove/~buffer stopped working?
    I have included an example that doesn't work on my computer. It's simply a copy of the entire ~groove help patch, so I guess that it ought to work...
    I am using Max/MSP v 5.1.4 in Windows 7

    • Jul 14 2010 | 10:19 am
      Try this patch to ensure that [buffer~] and [groove~] are working ok:
      copy above text and paste as New From Clipboard,
      If it doesn't work, check your DSP settings under Options, and also ensure you don't have any patches saved as "groove~" or "buffer~"; check the Max debug window aswell. Brendan
    • Jul 14 2010 | 10:58 am
      Ok, got it! Thanks a lot, Brendan. Your patch did some magic.
      At first I copied your patch into mine and couldn't get anything to work. But then I made a clean patch starting with yours and copied all my own subpatchers into that one. Then it worked!
      At no time I got any debug messages in the Max window, so I guess that my patch was somehow corrupted? Well, it works now, so I'm happy even though I still don't understand what made my patch corrupt.
      Thanks once more!