HELP still soundflower problem

    Feb 26 2006 | 12:19 pm
    I am working now for months on a big MaxMSP patch for live performance that i have to do in one week. Now i am already three days searching for a solution because a problem with soundflower.
    please see attachment '' with a simple, basic version of my audio patch to clearly understand the problem and the way of the audio stream.
    SETTINGS : 1.system preference > sound: output = soundflower (2ch) & input = line in / audio line-in port 2.MaxMSP DSP status: Driver>CoreAudio Build-in Audio / Input Device>Soundflower (2ch) 3.soundflowerbed: off !!
    > qtmusic goes to COREAUDIO > thru soundflower to adc~ > from adc~ to dac~ > NOT QTMUSIC SOUND BUT ONLY DAC~ SOUND have to come out the speakers into the air
    !! This was working in MaxMSP 4.5.3 on MacOS 10.3.9 !!
    ?? This doesn't work in MaxMSP 4.5.5 on MacOS 10.4.5 ?? also with the new soundflowerbed on, it doesn't work
    Otherwise i have to make a new work / patch in one week to do my concert.

    • Feb 26 2006 | 2:43 pm
      hi bart,
      without seeing your patch (no attachement) two suggestions: - try with aggregated devices (under 10.4.5 /audio/midi-setup): see if you cant route the audio from system-output elswhere to your soundcard. - if its only for qtmusic, why not use fluidsynth~ ? lets you have all the crappy midiinstrument -fun inside msp.
      hth hans
      hans w. koch im krahnenhof 11 d-50668 koeln +49-221-554902
    • Feb 26 2006 | 3:50 pm
      Try using Jack OS X:
      It will allow you separate the "default system output device" (which is what QT sounds come from), from the main dac~ output of your Max patch.
      At least I think that's what you're trying to do...
      -- Dan Nigrin Defective Records 202 Hack / PC-1600 User / VSTi Host / OMS Convert / Jack OS X
    • Feb 27 2006 | 2:50 am
      A while back there being a thread about this, try searching the archives for a thread titled "anyone with soundflower problems?" or "msp bug when input device != output device"
      I believe the ultimate result of those discussions was the realization that MSP has problems in 10.4 if the input device isn't the same as the output device.
      - Dave
    • Mar 02 2006 | 5:16 pm
      Hi, hans, Ok sorry, i have upload the patch, bizar! I have already tried with aggregated devices but it isn't working. Yeah, ok fluidsynth but i have maked my patch complete in function of qtmusic so that i can control every instrument/synth like i want.
      And before the soundflower problem it was really sounding like a real nice synth. But thanks i try, maybe my patch will work also with fluidsynth.
    • Mar 02 2006 | 5:21 pm
      Hi, Dan, Yes that is want i was doing with soundflower! I have again tried with Jack OS X. But MaxMSP crashed always when i try to do what i want to do. Bizar it also doesn't work with Jack!?
      Maybe the best thing that i can do is install back the ?old? MacOS 10.3.9 .
      Regards, Bart
    • Mar 02 2006 | 5:23 pm
      Hi, Dave,
      Aha, that's the problem that i have. Thanks! Ok, i will check that they, apple, have already a solution for that.
      Or, do you have a solution for that? Regards, Bart