hi (USB HID) SpaceNavigator acting weird in Windows

    Dec 09 2013 | 8:20 pm
    I recently had to move a project from OSX to Windows, and am having a hell of a time with the change in drivers. I have all but one of them resolved, the SpaceNavigator, a 3D mouse.
    In OSX using the hi node it reports values on channels 14-22. The the device is idle it reports values of zero, and any axis of movement sends +/- 1 to 512. Works great, I've used it a lot over the past few years.
    On Windows8-64, however, its a very different story. At first the device reported nothing at all, so I installed the manufacturer's drivers. The device works as advertised within windows and the applications it has specific profiles for. Unfortunately the hi node in MAX is sending what appear to be infinite incremental values in the positive or negative direction when an axes is moved. i.e. when you move an axes is starts counting positive or negative, when you release, the value stays, and if you move it again it continues counting from the same value. Whats even worse is I have seemingly no way to discern which channel is which axes, as the slightest touch sets almost all of them in motion. It behaves this way no matter what control profile is active in the manufacturer's software, even on profiles that have all the axes disabled.
    I tried removing the driver, reinstalling the driver, uninstalling the manufacturer's software, different USB ports, reinstalling MAX, and more, but the results are always the same. If its reporting, its reporting in the above described manner. I suspected something might be wrong with the hi object on Windows, so I tried a few other USB HID devices that I frequently use. While they do report slightly different values on different channels, they ass behave essentially the same way as they do in OSX, stopping at a specific value when idle, and incrementing or decrementing to a limit when adjusted. This leads me to believe that theres nothing at all wrong with MAX. It must be something to do with the driver that is being used by Windows.
    I contacted the manufacturer (3DConnexion) but essentially got a "nothings wrong with our stuff, it must be your IDE" in response. ()
    Might anyone have some experience or suggestions as to whats going on here? I'm quickly running our of time.
    cheers, -X

    • Apr 05 2015 | 9:51 am
      Did this ever get resolved?
    • Apr 21 2015 | 11:50 pm
      Unfortunately I never found a Max solution to this problem, instead relying on a byzantine solution based around AutoHotKey and a number of its 3rd party libraries. I'd be very interested to hear other's functional solutions.
    • Jul 08 2015 | 6:16 pm
      I'm getting the same thing :( anybody found a solution ?
    • Jan 23 2016 | 10:01 pm
      in the past few months I've switched from osx to windows 10 and got the same problem. Space Navigator doesn't work properly on Max7 Windows version and that's no alternative at the moment :(
    • Jan 24 2016 | 11:49 am
      Over the past few months i've switched from my ridiculously complicated AutoHotKey USB-HID system to one that uses EventGhost and local loopback UDP messages. It's much easier to setup & operate, and while local UDP seems like a silly solution it has the added benefit of broadcasting to other local systems such as Touch Designer.
    • Jan 24 2016 | 12:04 pm
      I also found this one, I'll test it tomorrow in studio.
      AutoHotKey is terrible. I'll try EventGhost
    • Aug 14 2019 | 8:59 am
      How is it now, 3 years later, on windows 10? Does it work?