HID and Logitech Gamepads. Mac and PC (0-255 vs 0-65535)

    Apr 03 2009 | 9:43 pm
    I just recently made the switch from a PC to a Mac and found that all the patches I made for my logitech gamepads are now broken. I kind of expected something like that but the big issue I'm having now is that on the PC my gamepads were giving me values between 0-65535 and now on my Mac I just get values between 0-255. That's a huge loss of precision.
    Anyone else having that issue? I know I can get 0-65535 out of it as my PC reads that fine.
    I'm just reading it using the "hi" object.
    Thanks, Scott

    • Apr 04 2009 | 2:23 am
      I'm guessing you were using a Logitech driver under windows and a generic OS X driver on your Mac? I have no experience with this specifically, but that is my hunch. I'm guessing Logitech doesn't make a OS X driver. Perhaps using something like USB Overdrive or Steer Mouse as your driver might help.
      There is my guess opinion. Just happened to be shopping for a new mouse (tired of the giant WASTE batteries using wireless is causing) and happened to read about people using those two programs with Logitech mice that don't have drivers on OS X.
    • Apr 09 2009 | 7:32 am
      I have had similar results with Saitek gamepads. I have raised this issue on the forum/mailing list last year I guess.
      I don't think it's a matter of driver. Actually there is no driver for Saitek gamepads on Macintosh. Furthermore, a long time ago during my first experiments with the Hi object I tried to install a free universal driver (it was still under MacOS 9) and it led the gamepad to be used to replace the mouse but couldn't be used for Max anymore. So I went on without any driver.
      I suppose that the difference of resolution between Macintosh and Windows platforms comes from different implementations of HId protocol.
      Could someone from C74 comment on this and maybe suggest a solution?
    • Apr 09 2009 | 8:36 am
      i have the same behavior here. it's been this way for years, and i think it will stay the same for a long time. the only solution is to handle the devices differently on mac an windows, with adaptable scales or bits shift. (>>)
      i have tested the new Saitek PS1000 analoguepad yesterday, it's a great device for mac (continous pressure sensibility on many buttons), but on windows, there is no pressure, even with the latest driver, and some button return strange values (-1 when the button is released on windows, 0 on mac...).
      if anyone has a technical explanation to that...
    • May 04 2009 | 9:35 am
      I've been trying to get a generic usb gamepad to be recognized by the HI object. The control panel recognizes it as a game controller; I can test and calibrate it, etc. and all of the buttons work. In Max, the HI object recognizes it as a "generic usb joystick" with 18 elements. However, the HI object refuses to output any numbers (stays at 0 and 0), regardless of which buttons i try, how fast i set the rate of polling, or whether i use metro, etc. Is this a driver problem? I tried a generic driver which didn't do anything. I tried the closest logitech driver, which didn't recognize the generic joystick and failed to install. Is this just not going to work with a generic controller? Do I need to buy the logitech one? Or am i just completely missing something obvious? Thanks!