High definition video playback in Jitter


    Feb 12 2013 | 7:27 pm
    Greetings,
    I've been trying to make a patch to display videos using Jitter, and I can't get my video (which is normally HD in quicktime) to be HD in Jitter. I've put my patch below; what can I change to improve the video quality?
    Thanks!

    • Feb 12 2013 | 8:31 pm
      i didn't test your patch but i guess you should define the resolution of the jit.qt.movie - or set it to @adapt 1, so it adapts to the incoming clip. best k
    • Feb 12 2013 | 10:20 pm
      The @adapt 1 makes the whole screen turn grey instead of changing the clarity of the image... Any idea why that would have happened?
    • Feb 12 2013 | 10:57 pm
      How about @dim 1920 1080?
    • Feb 13 2013 | 8:57 am
      you have to send "adapt 1" before loading the movie. If you change attributes while the movie is playing you have to reload it.
    • Feb 13 2013 | 9:41 pm
      Yoann, would you mind elaborating? I have re-loaded the video (with @adapt and now @dim as well), but it is still loading as a grey screen.
      Thanks, MM
    • Feb 14 2013 | 7:16 pm
      i have no idea what this grey business is all about. can you post your patch, and maybe take a screenshot?
    • Feb 14 2013 | 9:30 pm
      If you're still using the patch from the first post, your problem is you have Use Source Rect enabled on the pwindow. Disable this (in the inspector) and with @adapt 1 on the movie object, all works great :)
      Edit: ps If you're going to be outputting to the pwindow, enabling Interpolation on it will also help with the quality a little bit more.
    • Apr 12 2015 | 3:38 pm
      You need to add @interp 1 (or check the interp property in the inspector) on the window object