Inability to use any help file or tutorial that uses dac~

    Nov 20 2009 | 5:26 pm
    Due to M4L not allowing you to access dac~ users are unable to utilise any help file or tutorial that uses dac~. This is going to be a major hindrance to many people new to Max (myself included).
    I've been part of the beta programme since launch and never really noticed this before because effectively I was using a demo version of the full product (which has now run out) to learn ins and outs of the Max programming environment.
    Is there a workaround proposed so that M4L customers are able to benefit from these help and tutorial files also?

    • Nov 20 2009 | 5:48 pm
      Actually we did a lot of work to make sure that the audio would go into Live. Perhaps your demo expiration has produced an unwanted side affect.
      If you open DSP status, from the Options menu, are able to load the "Live" audio driver and get this all working right?
    • Nov 20 2009 | 6:09 pm
      Many thanks for the prompt response on this.
      I've already tried this. When I open the DSP status dialog I see the following:
      If select Live I am still unable to access my sound cards audio driver (Edirol FA-66 Firewire). The dialog shows as follows but is unreponsive. I'll try the same using my internal soundcard (MacBook Pro).
      If I click on the audio driver setup button the Max window reports - adplugrunner doesn't understand "setup"
      I'm using Live beta 10 and beta 9 of Max (you do not appear to have updated Max beta).
      Hope this information helps.
    • Nov 20 2009 | 6:23 pm
      The issue appears to be with a either with Core Audio or my Edirol soundcard (this sound card has been faultless wioth all other applications so I'll look into the matter further). After swapping back to my internal sound card the audio I now able to access audio in both the help and tutorial files.
      I'll let you know if I have any other problems.
    • Nov 20 2009 | 6:50 pm
      Ok cool, let us know. I'm not able to fault it here with an expired demo
    • Nov 20 2009 | 6:51 pm
      This still appears to be a bug of some sort though. The user has to switch on audio manually through DSP Status - not the most intuitive of things because your used to audio coming though Live for any other M4L integration.
      To make matters worse, if you require audio as part of a help or tutorial patch you have to switch audio on manually via the same steps each time you run Max (by pressing edit within Live). Max doesn't seem to remember this preference.
      This may however be unique to OS X.
    • Nov 20 2009 | 7:16 pm
      Ah ok, I see what you mean. Yes, this sucks.
      We'll have to come up with something.
      In the meantime, if you go into your Preferences in your User Library, Open the Max 5 Preferences folder, if you change the contents of audioprefs.txt to
      max v2; dsp prefdrivername Live; dsp prefsubname ;
      You should be ok
      Thanks for the report.
    • Nov 20 2009 | 7:20 pm
      Thanks for that. I'll let you know if I have any further problems.
    • Nov 20 2009 | 7:57 pm
      Andrew Pask wrote on Fri, 20 November 2009 19:16 Ah ok, I see what you mean. Yes, this sucks.
      We'll have to come up with something.
      In the meantime, if you go into your Preferences in your User Library, Open the Max 5 Preferences folder, if you change the contents of audioprefs.txt to
      max v2; dsp prefdrivername Live; dsp prefsubname ;
      You should be ok
      Thanks for the report.
      Andrew, Just to let you know I did as suggested and it still doesn't work. DSP Status shows that Live is selected but it is switched off and after you switch it on you then have to manually allocate the audio channels.
      Not to worry, I'll wait for a more permanent fix now I know it's on the to do list.
    • Nov 21 2009 | 8:55 pm
      i had this problem too on my macbook. a few weeks ago. this was a little confuse for me. because the dsp-status on my imac works correctly.
      but i havenn't found the problem after long search. last i had reinstall my computer system. after that the dsp-status works correctly.
    • Nov 27 2009 | 11:12 am
      HI, i installed last night the latest vervion from ableton and max for live. now i have the same problem again. but this time on my imac, max for live don't show me the right vector size which i set in ableton preferences to the sample rate of 512. and in ableton midi preferences doesn't anything from or to max/msp.
      during the beta i had this on my macbook. but the only way to fix this was a resinstall from my osx. after that it runs fine. i am not understand why is this now on my imac. since installing the latest version. he runs all time fine.
      i would be very thankfull to fix this problem. but on my imac is my complete software collection and music over 1 gb. and i don't like reinstall my os. because the insatlling from backup (software and music) costs to much time.
    • Nov 27 2009 | 7:14 pm
      i mean a TByte and not a giga
    • Nov 27 2009 | 7:21 pm
      We hope to have this resolved in the next update to Max and MFL. Thanks for your patience in the meantime
    • Dec 04 2009 | 11:05 pm
      I hope it too. A third time with problems in the DSP status dialog with the only way to fix this over a reinstall from the computer system would to be overkill. Indeed i make steady backups from my data and my system. But one time more would me make a little bit angry. Because i must invest a lot of time to bring my system and my data to the last state before reinstall.
      best -------- torsten
    • Dec 17 2009 | 5:01 pm
      i hope it don't come a third time. Now I have the DSP status dialog problem a THIRD ONE. From one to another day. Now, I am on that point to think about to sell my MFL License. Up to now i don't know the reasons for this problem and no instructions to fix this.
      i have no motivation anymore for a permanent reinstall from my computer system to fix this on this point.
      the first time was in the beta phase. where told me it is fixed for the next version the second one was after the official release. i send my files to ableton. they give instructions but they don't help. now the third one. I'm curious about what comes next. a reinstall from my computer system is absolutely out of question.
      i have no problems with bugs and so when i buy a new software product who is not long released. this is normal. on this point i can estimate that those important and fundamental functions work fine.
    • Dec 17 2009 | 5:09 pm
      Have you tried with the Max 5.1.1 beta release? Work has been done on this problem for 5.1.1.
      If it does not work with that then please contact us in support directly. I can assure you that we would never suggest reinstalling your OS for this problem.
    • Dec 17 2009 | 5:23 pm
      Yep i have installed but nothing have changed...
    • Dec 17 2009 | 6:21 pm
      Ok - as of 5.1.1 this should all be fixed for MFL only owners.
      PLEASE NOTE: Help file audio will only come through Live if you have an audio device with a plugout~ object in it open for editing.
      If you look in DSP status you will see the channel become active when your audio device is opened from Live.
      If any of you have problems other than this, then please contact support.
    • Dec 18 2009 | 12:36 am
      i have recently contact the support two times. the first answer was what you subscribe. but this is not the problem. i have send a new post back with a better subscription. but telediagnosis needs a little time to understand what the other one mean.
      the same that i have in the beta phase
    • Dec 18 2009 | 12:49 pm
      Hi Andrew, I can confirm that audio within tutorials now works automatically whilst running 5.11 beta with Live 8.1.1b3.
      It's probably worth noting though that for the Midi tutorials, the user has to place an instrument within Live to hear any form of output. This may be counter intuitive to some as a number of the tutorials mention connection to the operating system synths because the tutorials were not originally written for M4L users.
      Thanks again for sorting the initial problem out.