Inconsistent sound output from Max/MSP 6 via ASIO4ALL

    Jan 20 2012 | 2:48 pm
    I've recently started dabbling with Max/MSP 6 on my Windows 7 box, and I'm having a bit of a problem with the sound not always working. I've made sure my Realtek HD Audio driver is updated and that I have the latest version of ASIO4ALL, and I can consistently use Ableton Live 8 through ASIO4ALL with no problem, but I'm having trouble tracking down what might be the difficulty with Max. Sometimes the sound works fine, other times there's no sound at all, and I can't even pinpoint which condition is different between when it works and when it doesn't--All the settings appear the same in both cases. Is there maybe some process that isn't starting correctly? I'm stumped. Does anyone here have any ideas?

    • Jan 20 2012 | 3:03 pm
      funny that you come up with that, exactly my problem. i'm doing some tests at the moment but it seems to be the damned Microsoft GS Wavetable Synthesizer that is blocking the asio4all audio output. if i find out more i'll post it here..
    • Jan 20 2012 | 3:23 pm
      Interesting...I'll check that out when I get home from work. I wonder how Live is able to use ASIO4ALL if the output is blocked.
    • Jan 20 2012 | 4:34 pm
      the problem seems to be well-known, sol: disable "exclusive mode" for your audio outputs
      i took the steps described on this page, post no. 5 :
      additionally i had to restart before it worked.
    • Jan 20 2012 | 5:36 pm
      Thanks for the tip! Would disabling exclusive mode effect latency at all (assuming a bunch of things were not trying to grab the sound driver at once)?
    • Jan 20 2012 | 6:28 pm
      i don't think so and didn't noticed any change. asio4all highly depends on the cpu i think. i can go down to 64 samples with a buffer-offset of 2 ms in smaller projects, what was never possible on my older pc. maybe we should think about getting a proper audio interface instead of getting the maximum out of the onboard soundchip lol..
    • Jan 20 2012 | 10:19 pm
      Hmm...I tried disabling exclusive mode on all playback devices that had it, but this doesn't seem to have worked (or am I missing a step?). Now, when I start Max, it comes up with audio turned off. When I turn the audio on in the Audio Status dialog, I can see it access ASIO4ALL, but I still get no sound from Max (though sound from other applications seems unaffected).
      I also looked for some way to just disable the Microsoft synth, but couldn't find a way to do that either.
    • Jan 21 2012 | 1:21 am
      i was never able to mix 2 applications into the asiodriver, that works either with the mme or dx driver stuff or connect the apps with rewire.
    • Jan 21 2012 | 2:21 pm
      Oh, I should clarify...I wasn't trying to use more than one application with ASIO4ALL simultaneously. I have both Max (full version) and Ableton Live. I can still access Max for Live instruments/effects through Live, and those work fine "out of the box," with no need for ReWire. What I'm trying to do is use Max *without* Live as well--nothing fancy, no multiple programs--and that's where I'm running into trouble. With the playback devices set to allow exclusive mode, it sometimes works, sometimes not. With exclusive mode disabled, if I bring up Max--on its own--it comes up with the audio set to Off. When I then turn the audio on, I can see the status message from ASIO4ALL telling me that Max is connected to ASIO4ALL, but I still get no sound.
    • Jan 25 2012 | 9:39 pm
      I have made partial progress with this issue. I've disabled exclusive mode for all playback devices. While I still have to turn audio on in Max each time I start it, I can now get sound from it through ASIO4ALL, but through the right channel only. In the ASIO4ALL panel, only the Realtek HD Audio output and Realtek Audio Front Mic input are turned on. I've tried several other combinations, with no results. No other programs are currently accessing ASIO4ALL except Max.
      Does anyone have any ideas?
    • Jan 26 2012 | 3:01 am
      when i read your first post again, i notice, you're talking about a virtual maschine. that might cause other problems and will not give you a stable environment to work with max or audio generally. good luck with this. btw : google gives you endless hits with a4a problems and solutions.
    • Jan 26 2012 | 12:12 pm
      Actually, no, I'm using a Gateway tower with a quad-core AMD and 8GB of RAM, no other OS's except Windows 7 installed, so Max is running in just a plain old Windows environment. Anyway, I'll keep poking around and see what I can do.
    • Jan 26 2012 | 12:17 pm
      oh ok, you wrote win7 box and i was thinking of virtual box. i'm sure you can fix it.
    • Feb 02 2012 | 9:46 pm
      After many, many dead end Google searches, I finally solved this. I found that the problem was in the Realtek HD sound manager. What I had taken to be a main volume control--since it is labeled "Main Volume"--was actually what I would call a Balance control, and it was pushed all the way to the right, thus only allowing the right channel through.
      I simply cannot say "D'OH" loudly enough.
      Now I have good, consistent stereo output from Max through ASIO4ALL and I can really get started learning this awesome environment.