Internal Mic Not Working with Max/MSP


    Jul 14 2010 | 9:12 pm
    Hi - my internal mic is working with Audacity, and is working during my System Preferences check, but when I select "Built in Microphone" as my input device for Max/MSP, [adc~ 1 2] does not output any signal. What could be the problem?

    • Jul 15 2010 | 12:24 am
      It might be worth checking the in/out mapping and that you're using the correct driver in max, it can all be done from the DSP Status window.
      lh
    • Jul 15 2010 | 2:23 pm
      yes, i have been using Max/MSP for a few years now and am intimately familiar with the DSP window. i have used the internal mic before when working with Max and am using the correct driver (Core Audio), and have selected the correct in/out mapping. Recently, I installed the driver for the MBox2, but I don't see why this might affect the performance of my Core Audio driver? The internal mic, as I mentioned, is working for other applications (Audacity, Ableton Live, System Preferences). It is only in Max/MSP where no signal is coming through my [adc~ 1 2] object.
    • Oct 22 2011 | 8:11 pm
      Any response to this question? I am having the same problem with Lion and I can't figure out what to do next. My internal mic registers in all other programs except for Max/MSP. Please help!
    • Jan 02 2012 | 11:09 am
      I am having this problem as well - anyone figure it out? I also recently installed Lion
    • Jan 04 2012 | 3:11 am
      I had lots of problems on Mac Powerbook Pro after upgrading from Snow Leopard to Lion this holiday until I upgraded to Max 5.1.9. If you haven't tried that might give it a shot...
      Andrew Pask will know more.... see Download page older versions,,,
      Hope this helps,
      Gord
    • Nov 14 2012 | 3:28 pm
      Hey guys if you want to work with internal mic in Lion i have the solution.
      1) Open Audio Midi Setup (Applications / Utilities / Audio Midi Setup)
      2) Window menu show audio devices if you can see audio devices forget this step.
      3) Lefts side down, make a click in plus ( + )
      4) Create Aggregate Device
      5) You have now a blue device in the list with the plus called "Aggregate Device" make double click over the name an write: "MAX INTERNO"
      6) Now you have a new Aggregate device, in the right side check under the word "use" Built in Input and Built in Output also.
      7) If you have MAX MSP open quit and re-open
      8) Open DSP Status
      9) In diver select Coreaudio MAX INTERNO and turn on
      10) We can use the mike know
    • Nov 16 2015 | 10:05 pm
      Thanks a lot Goldfish. This worked for me too, when I upgraded to Yosemite.