is soundspotter~ external working in Max 5.1.7?

    Jan 23 2011 | 9:52 pm
    Hi, im trying to use the external soundspotter~ but i receive the errors: soundspotter~: unable to load object bundle executable 2011-01-23 22:33:47.087 MaxMSP[234:207] Error loading /Applications/Max5/Cycling '74/msp-externals/soundspotter~.mxo/Contents/MacOS/soundspotter~: dlopen(/Applications/Max5/Cycling '74/msp-externals/soundspotter~.mxo/Contents/MacOS/soundspotter~, 262):
    Im getting the patch for OSX Intel from here:
    Someone experiences the same?

    • Jan 25 2011 | 11:27 am
      Hi I think it comes down to : Library not loaded: /usr/local/lib/libavcodec.dylib I think you need this on your system. It's part of FFMpeg library Cheers
    • Nov 24 2011 | 3:09 pm
      Hi, sorry to dig up an old post but I'm having the same problem.
      I have tried to install the FFMpeg library to get soundspotter~ to work but am having no luck.
      Has anyone managed to do this successfully yet? I'd really love to get this external working.
    • Nov 24 2011 | 7:14 pm
      Just to confirm I am using the latest version of Max5 on OSX Snow Leopard.
    • Dec 04 2011 | 5:53 am
      I just got this working! FFMPEG can be compiled in a "static" or "shared" form. We want the shared form, which means several dynamic libraries (".dylib" files). I couldn't find a direct download for Mac OS 32bit (seems like 64bit is here: but some apps use ffmpeg internally so they include the libraries. pyTivoX for example:
      2) right-click on and choose "show package contents". In contents/Resources find these files: libavcodec.dylib libavdevice.dylib libavformat.dylib libavutil.dylib libswscale.dylib
      3) Copy them to usr/local/lib (use Terminal commands or search the web for how to show and hide invisible files in the finder)
      4) Restart MAX and soundspotter should be OK. Hooray!
    • Feb 28 2012 | 1:39 am
      Thanks for the solution, zip. In case anybody does what I did and winds up with the 64bit versions of the .dylib files instead of the 32bit, you'll also be getting this as part of the error message:
      mach-o, but wrong architecture
      Switch to the 32bit versions and that should resolve it.
    • Feb 29 2012 | 12:25 am
      I'd recommend using MacPorts for installing this kind of stuff. You can find most open source software you'd want to install this way and easily keep it up to date. Yes you have to use the Terminal, but there are not so many commands. For example, to install FFMPEG, you just would enter in the terminal:
      sudo port install ffmpeg
      Although at the time I did this last, some of the libraries FFMPEG relies on had trouble building, so I built the universal variant and everything went fine—using this command:
      sudo port install ffmpeg +universal
      I know Michael Casey has on his todo list to make a version of soundspotter~ that does not depend on these dynamic libraries—perhaps I may help out with this because I'm planning on writing an external based on some of the analysis algorithms in soundspotter~, I'm just waiting on a new version of the code Michael told me about where he already took care of some things I was going to add (like not having a fixed signal vector size of 2048).
      P.S.: As I noticed when I just tried to open a patch with soundspotter~ for the first time on a new HD and noticed I had the same error because MacPorts normally installs in /opt/local not /usr/local (personally something I like), so you either need to change the MacPorts install directory to /usr/lcoal or make symlinks in your /usr/local/lib to the right .dylibs in /opt/local/lib.
      The bottom line is I've been few this a few times with soundspotter~, so if anyone finds this thread and has problems, feel free to send me a message with this new private messaging service (if I don't see your post about it because I go through periods of daily reading of these forums to none at all).
    • Jan 14 2014 | 3:10 pm
      @Roth, there is no PM anymore... Is there a working, self-contained, soundspotter~ external for Max6 somewhere? Or even for Max5?