Java problems (maxj, FTM)

    Mar 04 2006 | 8:10 pm
    I have been running MAX/MSP very successfully for several months on a group of 4 identical 2 Ghz iMAC G5s. Significantly (as will be explained shortly), I did not try to use any maxj objects.
    About a month ago, I installed IRCAM's FTM package on these computers, as well as a 2x2Ghz Power Mac G5 and an 867Mhz Powerbook G4. The FTM objects worked fine on the Power Mac and Powerbook, but not on the iMacs. Once I installed the FTM package on the iMacs, I had to remove the _FTM_.pat file from the startup folder just to keep MAX/MSP from crashing on startup. Even then, when I would try to create an FTM object, MAX/MSP would hang (spinning rainbow pinwheel) and I had to force quit. I spent several weeks posting to IRCAM's FTM forum regarding this problem and tried literally dozens of fixes. Finally, someone suggested that I try to open a maxj help file to see if there was a broader java problem. In fact, when I tried to open any maxj help file (on any of the four iMacs), MAX/MSP would hang (just as with the FTM objects). At that point it became clear that this was not a problem with FTM, and it was suggested that I post the problem to this forum.
    Has anyone had a similar experience with iMac G5s? Anyone have any ideas what the problem might be?
    Thanks MDV

    • Mar 05 2006 | 8:09 am
    • Mar 05 2006 | 5:08 pm
      We have encountered this problem with FTM once before with someone making a standalone. In that case we were able to fix the problem by making sure that the versino of the max.jar file on your computer is up-to-date. I'm not sure, but I suspect that the installation of FTM causes a conflict. Please uninstall FTM, uninstall Max, make sure there are no lingering copies of max.jar anywhere on your hard drive, reinstall Max, and see if mxj works. If that doesn't fix the problem please email and we'll try some other tactics.