jhno's cellsound for osx (anyone have it ?)


    May 15 2006 | 12:32 pm
    would anyone happen to have jhno's cellsound for osx that they could mail me i have an idea for making something similar for a dance piece, and i'd like to show jhno's patch to some people later today (or at least ASAP) ... unfortunately i just realised that i only have it for OS9 (and of course my 'presentation' mac is OSX ) and apparently there is a problem with the download page at
    (which brings you back to the main share page instead of providing a link to the file)
    so if anyone happened to have it handy, that would be much appreciated
    thanks in advance martin wheeler paris

    • May 15 2006 | 2:57 pm
      OK, sending a copy to you now, cheers Roger
    • May 15 2006 | 3:12 pm
      I would appreciate having a copy too.
      Cheers, Gary Lee Nelson TIMARA Department Oberlin College www.timara.oberlin.edu/GaryLeeNelson
    • May 15 2006 | 4:26 pm
      thanks Roger, but what you sent me appears to be the OS9 version (created/modifies dates are 20 July 1998) and doesn't work on OS X - it needs to see an object called ca1s (you sent me an OS9 version of this object but that doesn't work in OS X) and there are possibly also other issues. Cellsound has been rewritten by jhno for OSX, and i think that ossibly this object (which doesn't appear to exist for OSX- at least i can't find it in the usual places, nor with googlesearch) is no longer needed ??? In the OS9 version there is also use of the unit object which i think might have issues or need an update for OS X ...
      what i need is jhno's cellsound for OSX package, or a working link to this (as i said there is a problem with jhno's page at c74)
      > On 15 mai 06, at 15:20, Georg Bosch > wrote: >> Hey there, >> >> found this on my disk, doesn't seem to be os specific, plays fine >> in osx. >> cheers, g. >> >
      thanks george but are you sure this plays OK for you ? while the name (cellsound v1.0x) & modification date: 19 Feb 2004 makes it seem likely that this is the OSX version, it still gives me an "error : ca1s : no such object" message (i tried with the OS9 ca1s object & it definitely doesn't work ...) maybe jhno has rewritten the ca1s object for OS X ? but if so, i can't find it anywhere. Do you (or anyone else) have an OSX compatible ca1s object ? in any case, if max doesn't give you an error message on launching cellsound, could you send me your ca1s object so i can try it with that ...
      thanks for any help
      Martin Wheeler Max/MSP 4.5.2 G5 2X2.5 GHz
    • May 15 2006 | 5:50 pm
      hi roger thanks again for your time ... but that (new) zip file is in fact the same one that Georg sent me ... and it gives me an error 'cos it can't find the infamous ca1s object ... (i have the OS 9 version of in my max searchpath, but it doesn't see it, and anyway from what i have read on the net, that version of ca1s isn't supposed to work with OSX anyway) and in fact the patch opens with ca1s as a 'bogus object" ... (between pack nrand/ prepend set & s viz) and doesn't work at all (which isn't surprising because,in the OS9 version ca1s contains the cellular automata algorithm) i don't get what is happening on your system that isn't on mine ... !!!???
      when you open the patch do you see a (non-bogus) ca1s in there ? if not what ? and if so, do you have an object called ca1s in your OS X max searchpath ? and if so _please_ could you send it to me !!!
      thanks again for your help martin wheeler
    • May 15 2006 | 6:14 pm
      Am 15.05.2006 um 18:26 schrieb Martin Wheeler: > but are you sure this plays OK for you ?
      As others wanted it too, i put it here: http://www.stillavailable.com/cellsound040220.sit asuming this is ok with the author.
      Unstuffing it gives me a folder with the patch, an abstraction called unit, and the object ca1s plus a folder containing its source. All working fine.
      cheers, g.
    • May 15 2006 | 6:59 pm
      Hi Georg thanks a lot i downloaded that one & it now works fine fantastic presumably the first try that you emailed me must have got corrupted somehow ... anyway all is good now - thanks again, and to Roger too, for your help best martin ps i should think it would be ok with jhon, as there is it is supposed to be available on his page at the c74 site ...
    • May 15 2006 | 7:24 pm
      Wow ! Nice ! It's been weeks since I tried to remember where did I see such a site with a pink background and that cute rabbit. Here it is.
      Aaaah. It made my day once more. I hope you don't mind if I bookmark it. :-)
      Julien.