jit.anim.drive doesn't want to read a dictionary

    Nov 18 2012 | 6:13 pm
    when using jit.anim.drive, you should be able ot load a .json Max dictionary containing the mappings you're wishing with UI elements of your choice. But despite how hard i try, it never happens and jit.anim.drive always use the default mappings. I try to use @ui_map [namofdict.json] attribute ; also tried @ui_map [namofdict] and also by directly connecting a dict output (of a [dict nameofdict.json], which does indeed load the named dict) but nothing works. Only thing working is by manually editing the jit.anim.drive dictionary content. Moreover, it doesn't say anything to Max windows, nore to the dump output. AM i missing something here ? or is this as much a bug as i'm thinking ? joined is a minimal patch showing my unsuccesfull attempts

    • Nov 19 2012 | 4:52 pm
      hi vichug. your example works for me as expected. what version of max are you running? make sure you close the anim.drive's dictionary window before reading in a new dictionary.
      if you can provide some steps to reproduce where this is not working, please let me know.
    • Nov 19 2012 | 6:08 pm
      Hi, thanks for helping. Mac is osx 10.6.8, Max is 6.0.8. As stupid as it might sound, it is not impossible that the problem was coming from me not closing the dict editor of the [jit.anim.drive] while trying to load another one... cause i did succeed in loading a dict into [jit.anim.drive] right now, by dumping the name of the dictionary.
      That beeing said, the patch i shared was uncomplete, my point was that i tried to use the @ui_map attribute
      which is supposed to load a .json file, and doesn't load it for me. That does not work here. It does not work when i : -have a named .json file inside Max search path, which i'd like [jit.anim.drive] to load at startup -create a [jit.anim.drive @ui_map something.json] ; at which point i would expect the something.json to be loaded inside [jit.anim.drive], but when i double click [jit.anim.drive] it's still the default dict. -save the patch, re-open, at which point i would expect the something.json to be loaded inside [jit.anim.drive]
      Do i use the right attribute flag for that ? Is there something fishy about my file format ? Something to know about creating the .json, or placing it somewhere special, or not modifiying it while Max is running, etc ?..
      When it worked, i did : -call successully the .json file with a dict -link the dict to the [jit.anim.drive] -bang the dict, which outputs a "dictionary something" message directly to the left inlet of the [jit.anim.drive]
      Though i've been also having a weird thing, for some reason, couldn't tell exactly the steps to reproduce... the thing it did was revert the content of [jit.anim.drive] to the default, as well as the content of my named [dict] object (and i had supposedly no backward connection going from the jit.anim.drive towards the dict, so that makes it weird... and the .json called by the dict remains untouched)
    • Nov 19 2012 | 7:57 pm
      yeah, there's some obscure bugs when providing the ui_map attribute in the anim.drive box. i recommend doing what you did in the first patch, and simply bang the dict to the anim.drive with a loadbang
      i'll take a look at these issues for a future update.
    • Nov 19 2012 | 9:36 pm
      ok, thanks ! i'll do that.