jit.gl.lua RTT


    Mar 13 2008 | 9:19 pm
    Hi,
    I'm trying to use RTT with jit.gl.lua, but it doesn't seem to be working. I figured a good start would be the RTT.capture example patch that comes with jit.gl.lua. On my system the window stays black. I don't see anything. Selecting the backend, FBO gives me the following errors:
    jit.gl.fbo: unsupported framebuffer format! jit.gl.fbo: error updating framebuffer attachment!
    For the RTT backend there are no errors, but still the output is empty. I've also tried the RTT.slab example. This one doesn't work either but odly the fbo backend doesn't generate errors in this patch. Both backend options just show a black screen.
    I'm using the latest max/jitter/jit.gl.lua on an intel mac running 10.5.2with an NVidia 7300GT
    Any ideas?
    I'm already trying this as an alternative to the accum buffer which I failed to get working. I'm running out of options.
    Cheers, Thijs

    • Mar 13 2008 | 9:31 pm
      Here's the most trivial RTT example. If this doesn't work then something is out of whack.:
      Script----------------------------------------------
      local scene = jit.new("jit.gl.texture", this.drawto) local vplane = jit.new("jit.gl.videoplane", this.drawto) vplane.transform_reset = 2 vplane.automatic = 0 vplane.texture = scene.name
      function draw() jit.gl.begincapture(scene.name, 0) gl.Begin("TRIANGLES") gl.Vertex(-1, 0, 0) gl.Vertex(0, 1, 0) gl.Vertex(1, 0, 0) gl.End() jit.gl.endcapture(scene.name, 0)
      vplane:draw() end
    • Mar 13 2008 | 10:21 pm
      On Thu, Mar 13, 2008 at 9:31 PM, Wesley Smith wrote:
      > Here's the most trivial RTT example. If this doesn't work then > something is out of whack.: > > Thanks Wes, it appears to work. At least for the RTT backend. FBO still generates the same errors I reported earlier. I tried to find where the difference is and the problem appears to be the slab. If I take out the slab from RTT.capture.lua.demo then the patch works. If I use the slab, I see only the first frame (without effect) and then the screen goes black. I can see the first frame again by reloading the lua file.
      I tried co.inverse.jxs instead of wobble, but the output is the same. Any more tests I could do related to the slab issue?
      Btw, is FBO going to give a lot better performance over RTT?
      Cheers, Thijs