jit.gl.slab glow effect makes my particle system disappear. Why is that?


    Nov 14 2016 | 9:36 pm
    Hi guys!
    I'm working on this particle patch based on a patch from the example library. I added a glowing effect that uses jit.gl.texture and jit.gl.slab, but weirdly enough the effect makes my jit.gl.mesh based particle system to disappear when i send a bang to the blur subpatcher! Could anyone explain to me why it happens, and how I can work around it, to apply my glow effect to the particle system? If you remove the pink patching cable going from the trigger object to the "blurstuff" subpatcher you'll see the particle system appear.
    I'd appreciate a quick answer!
    Best wishes, Jonas

    • Nov 15 2016 | 10:29 am
      I believe the videoplane you render the blurred gridshape to covers the particles. Either: - draw the particles after the videoplane with automatic 0 and explicit ordering, - turn on blending and use an additive blending mode ("blend_enable 1" and "blend add").
    • Nov 15 2016 | 4:56 pm
      here's the modern way to do this, using jit.gl.node:
    • Nov 15 2016 | 6:06 pm
      Wow, very cool rob! I still have so much to learn in jitter, it's very inspiring to see new objects I don't understand cleaning up something. I'll study jit.gl.node! Thank you!
      Thanks for answering as well, Pedro!