jit.glue and jit.alphablend, bizarre text overlay issues


    Apr 25 2006 | 12:20 pm
    I'm using jit.scissors and jit.glue to split up a matrix and glue it back together again, and then using the Jitter tutorial patch 29 to overlay text on the top. However, it really doesn't work with different column numbers in jit.glue, and I can't for the life of me see why. Any help would be much appreciated.
    Example below.

    • Apr 25 2006 | 3:17 pm
      Hi Ed, I found your problem. This issue has stumped me in the past. There seems to be some rounding error in jit.scissors as it tried to divide the incoming matrix. I changed all the matrix dims to 320x240 'cause it chunks my machine otherwise. In any case, one of your scissor/gue combos it outputting a 318x240 matrix instead of 320x240. jit.pack really rally hates inputs that aren't the same size and thus gives you a black output. Check it out:
      wes
      PS consider using jit.gl.text2d and jit.gl.videoplane for overlays...will be much faster.
    • Apr 26 2006 | 10:58 pm
      So... we found a bit where Max is broken? Fair enough then I guess. I'd tried using jit.gl.text2d to overlay the text before, but I couldn't get the video underneath to show through how I'd wanted. I must have missed something obvious. Ah well, back to the drawing board. Thanks for the help.