jit.net.send Mission Impossible

    Jun 23 2013 | 8:01 pm
    Hello all.
    I have used network communication with Max many times successfully. I am currently testing a system that uses jit.net.send/rcv for tcp communication over WAN networks. All possible configurations have been made (port forwarded, static ips, firewalls, etc) but I can't connect from a client to the server!!!
    If I use the help file of jit.net.send with the external ip of the receiving computer (btw in this example the same computer with its external ip) and the port number, which is open and tested with Network Utility, Terminal and websites like http://www.canyouseeme.org/ everything shows that my port is open. If I change the external ip to localhost or stream in the local network everything is fine. I can't explain why it is not working with the external ip!!!
    Please, if someone has an idea to fix this let me know....cheers!!!
    ***also to add that using the command netstat -an |grep 7502 |grep LISTEN in terminal I get the following error....does it mean that I don't receive any data from the jit.net.send object? Why is that?
    netstat -an |grep 7502 |grep LISTEN tcp4 0 0 *.7502 *.* LISTEN

    • Jun 24 2013 | 2:46 am
      After some further tests, I noticed that the command line gives me a SYN_SENT state of my current port. I believe that there is a possibility to have a problem with my router or ISP? How can I corrent this and send/receive the message in full?
    • Jun 24 2013 | 4:01 pm
      Need to bother the forum again with this problem, only to update:
      I called my ISP and made sure that no additional firewalls between me and the "internet" are there. Everything is open. I have also checked a Windows and Mac machine in the same network. I have also checked the same configuration in another network (everything seems open again, but I still get the message SYN_SENT from the console). I also tried UDP messages using WAN address...still nothing.
      ***Using other programs cause the same effects, which means that Max is not the issue but a problem in my congfiguration. However, if someone can share an idea to help me troubleshoot, that would be great.
    • Dec 09 2015 | 5:30 am
      Hello Stavros,
      I was wondering if you ever got the jit.net.send over WAN to work. I am thinking about embarking in a project soon that is very dependent on this feature, so curious if it will work...