jit.qt.grab deinterlace


    Feb 27 2014 | 11:31 am
    Hi,
    I have a patch with jit.qt.grab and want to deinterlace the incoming video, which is 1080i
    How can I do that??
    Cheers

    • Feb 27 2014 | 8:44 pm
      If you send a "singlefield 1" message to jit.grab you can throw away one fieldset, but that cuts your vertical rez in half.
      There's a simple de-interlacer shader included with MAX:
      (Cycling 74 folder / jitter-shaders / convolution / cf.deinterlace.jxs)
      Or you can try vade's de-interlace shader v001.deinterlace.jxs (attached to this post - seems to be gone from the internet these days?)
      I think both shaders do simple field mixing, so they look better than "singlefield 1", but you won't get full sharpness either. You can read about smarter de-interlacing methods on the VLC wiki (none are available in MAX though).
    • Feb 27 2014 | 8:47 pm
      Thanks, will try and see how it works out
      Cheers
    • Feb 27 2014 | 8:50 pm
      Hi,
      Tried "If you send a singlefield 1 message to jit.grab you can throw away one fieldset, but of course it lowers your vertical rez." Jit.qt.grab doesn't understand it??
      Weird
    • Feb 27 2014 | 9:10 pm
      Perhaps the new QTKit grabber in 6.1.6 / Mavericks lost the singlefield capability? Or maybe some digitizers don't support it? I've used it many time for DV inputs.
    • Feb 27 2014 | 9:15 pm
      Hi,
      I just saw in the help file that's it's digitizer dependant. Will try the shader instead.
      Thanks again
    • Feb 07 2017 | 1:55 am
      Hi
      I'm trying to deinterlace footage captured with jit.grab.
      I need some very basic advice as to how to wire up the shader.
      I've posted the patch with what I suppose are the basic elements needed.
      Thanks
    • Feb 07 2017 | 3:54 pm
      it's a texture processing effect, so you use jit.gl.slab.
      also, you can enable output_texture on the jit.grab for improved performance, since you're going straight into GL land with the deinterlace shader.