jit.vcr patch problems

    Dec 20 2012 | 9:04 pm
    So, I know that jit.vcr is full of problems and weird idiosyncrasies, but I was wondering if anybody has any advice for this problem. I have jit.vcr working in my patch in max, but when I build it as an application, jit.vcr stops working. I've tried directly sending it a "write 30. jpeg normal" message and it doesn't do anything. I don't know of any parameters that have changed, so I'm confused as to why it would work in Max but not as a standalone. Any advice or ideas would help, thank you!

    • Dec 20 2012 | 11:03 pm
      are there any error messages in the max window?
      my guess is that you can't really use relative paths in standalones. you need to provide the full path of the file to the write message.
    • Dec 22 2012 | 6:46 pm
      There weren't error messages before, but I'm actually getting a "DSP must be enabled before writing" error. I tried sending a '; dsp start' message to max, but I got the same error. I feel like I have seen people complain about this before, is there an easy fix?
    • Dec 22 2012 | 7:37 pm
      I played around with it some more and now I'm getting a "no midi driver folder or default driver", "MSP/ad: no ad folder", "Core Audio: No such object" and then a few from spigot~ that I'm guessing are because of those first three errors. Where do I make these folders?
    • Dec 22 2012 | 8:22 pm
      Okay, I managed to get a pretty kludgy-feeling solution by just copying over the entire "msp-externals" folder from the Cycling '74 folder. It seems to work regularly now for the most part. Also, turning on "audio support" in my standalone object ;)