jit.world in M4L -> buggy?


    Sep 14 2020 | 8:35 am
    Dear all,
    I'm trying to include a jit.world into my M4L set, but it behaves quite weird:
    When I open the .amxd in Max it works perfectly fine 100% of the time ( its just a simple jit.world + jit.gl.videoplane playing back a simple video).
    But in M4L the jit.world doesn't seem to "connect" to the videoplane. It sometimes works, then I close the patch and it doesn't anymore. Restarting everything doesn't fix it. Then 1 day later it works again, just to break on next startup again so very weird behaviour.
    Connecting a jit.window or pwindow or gl.render to the videoplane all work fine, so the problem must be within jit.world (my guess would be some internal instanciation / naming problems?)
    Anyone else ever had such problems and might have a solution?
    PS: MacOS 10.13 / MacBookPro
    Happens on multiple computers too!
    Many thanks
    hoowdie

    • Sep 14 2020 | 5:34 pm
      Any error messages in the Max console? If you manage to reduce the amxd to a simple version showing the problem, don't hesitate to share it here, that might help get more answers.
    • Sep 15 2020 | 2:27 pm
      Hi Hoowdie, thanks for the report. I know there are issues with jit.world in the context of editing MFL devices and I will be looking at solutions for this, either near-term patching solutions, or longer-term engineering solutions.
    • Sep 15 2020 | 4:36 pm
      Hi Hoowdie, I am trying to isolate the situations where this breaks, and as you surmised it seems to be related to context and sub-context naming in the jit.world.
      Can you please send along the device that is not working for you, as that will help me narrow this down (i know you mentioned it is a simple device, but the specifics of order and arguments are important here).
    • Sep 15 2020 | 4:57 pm
      ok, I seem to be getting the best results if i use the "---" (three dashes) auto-naming feature of MFL to name the any world contexts or jit.gl.node sub-contexts, e.g: [ jit.world ---world ] [ jit.gl.node ---world @name ---node ]
      OR simply leave the name argument blank to enable implicit context naming. If you are only dealing with a single jit.world main context, then you should be able to only name that context and leave all other drawto arguments blank (enabling implicit context finding on those objects).
      For more complicated scenes, explicitly name each context using the three dashes. Please check out the following patch as a new device and let me know if that technique works for you.
    • Sep 15 2020 | 5:30 pm
      Hey Rob,
      sorry for my late reply, I didn't see it earlier.
      Thank you for looking into the problem, I will try your suggested solution and see if I can get it going :-)
      Thanks very much!
      hoowdie
    • Sep 15 2020 | 10:17 pm
      Thats odd, i've never had any huge issues concerning jit.world im my complex m4l jitter devices. Its this concerning to gl3 or a specific max version?
    • Sep 16 2020 | 8:36 am
      Well I only tried it now with Max 8.1.4 ++ , so don't know if it might be a new problem?
    • Sep 16 2020 | 2:39 pm
      HERR MARKANT, it should not be specific to glengine or max version, and probably only affects the specific use case I identified above (explicitly named contexts without using triple-dash).