Jitter - getting video dimensions above 720 x 576

    Sep 20 2021 | 8:57 am
    I have a patch in which a video is played using jit.movie~ and then various FX are applied and the result recorded by jit.vcr. You can of course tell jit.vcr. what dimensions to make the final movie so as to keep the aspect ratio of the original, but up to 720 x 576 it will do it automatically. In other words play a movie of say 640 x 320 and your VCR movie will automatically also be 640 x 320 without doing anything else. This works for all sizes up to 720 x 576 and then after that unless you set the dimensions the final movie will be 720 x 576. I wondered if there was anyway to get the actual dim from the original movie and then feed them to VCR so as to automate the process for any aspect ration but interestingly jit.fpsgui which as the dim out only reads movie dimensions up to 720 x 576 but anything above that size is read as 720 x 576. Is there a way round this?

    • Sep 20 2021 | 11:15 am
      OK upon further exploration the problem is occurring only with a certain number of movies I have that though they look like 1024 x 576 are in fact 720 x 576, 16:9. When I tried exporting them in QuickTime as 1024 x 576 they then show up in the right aspect ratio on the jit.fpsgui dim output.
    • Sep 20 2021 | 11:19 am
      Have you tried to set [jit.vcr @adapt 1] to make it adapt to the incoming dimension of the matrices?
    • Sep 20 2021 | 11:55 am
      jit.vcr seems to adapt automatically to match the incoming dimensions even without @adapt - the problem is with movies that are in the 720 x 576 and 16:9 ratio. If you play these in say QuickTime they are automatically stretched and appear on screen as 1024 x 576. Jitter seems to see them as 720 x 576 however. A simple answer would be to avoid these movies I guess or provide some warning to users.