Kinect Tracking

    Feb 25 2011 | 4:07 am
    Ive gotten my Kinect to send the ir, rgb and the depth map to max (using the fantastic jit.freenect.grab by JMP) Im wondering how I can track objects using the depth map. Any ideas?
    Im also interested in the OpenNI/NITE middleware solution and have followed Tohm Judson's technique (, but to no avail.
    Ive gotten the OSCeleton to calibrate but can't seem to get Max to receive the data (sometimes, it actually crashes max...)..
    Has anyone tried this yet? Any ideas?
    thanks -Levy

    • Jul 03 2011 | 10:23 pm
      Hey i experience the same problem as you, osceleton work, but nothing happen in max. did you fix it?
    • Jul 07 2011 | 12:46 am
      i had to use the older version osceleton 1.0, not the latest 1.1 version to get numbers in max.
    • Jul 07 2011 | 12:58 am
      true, its the only way i found to fix it! but apparently:
      thank you
    • Jul 07 2011 | 4:22 pm
      ah yes. changing the default port did work for me too for version 1.1. nice.
    • Sep 29 2011 | 12:39 pm
      If you are Windows, easy to use my jit.openni object at
      Pretty extensive functionality see the wiki also there for full documenation.
      *Robert*, I'm interested in the chromatic abb shader your posted 2 years ago at Is there a way to get that from the archives or directly from you?
    • Oct 28 2011 | 12:34 am
      Excellent! diablodale
      you really do a great job .
      But when I execute "jit.openni_test1.maxpat", it appears the following warning:
      " Can't find entry point xnRegisterToCalibrationComplete in OpenNI.dll "
      Do you know how to fix the problem?
      Thank you~
    • Oct 28 2011 | 5:56 am
      PS. I use XtionPro Live...
    • Oct 28 2011 | 11:10 am
      That error suggests to me that you don't have the required version of OpenNI installed. Please check my wiki at and tell me if you have those versions instaled.
    • Oct 28 2011 | 11:51 am
      Thank you so much diablodale! The problem is solved ,it's version situation.
      Now I installed as following :
      OS : win7 64bits OpenNI : v1.3.3.6(x86) Nite : v1.4.2.4(x86) PrimeSense : v5.0.4.3(x86)
      But when I installed openNI(x64),Nite(x64),PrimeSense(x64) , it can't work!
    • Dec 14 2011 | 6:44 pm
      Hello, my question fits into the Kinect category but a different issue. so I am trying my luck here.
      I use osceleton to read my body movements and use tohm judson's patch to obtain and send data to jitter patch. now, i have a bit problem to do data mapping, i.e. I want to bang a message box using the data i receive, but it is so unreliable, sometimes it bangs, sometimes it doesnt... am i missing something here?
    • Feb 26 2013 | 9:44 pm
      Hey all, I have been SCOURING these boards trying to limp through the Tohm Judson tutorial. I've gotten to the point where I need to download NITE and then install it then run it with a test. I have downloaded and installed it correctly. Apparently the new additions dont require you to enter the code in so I am fine with that. Its when I need to copy the three files I get lost, i just cannot find those three files at all. When I skip that step and try to run the Sample-PointViewer program i cant even find it within the download file. I have simple hand tracker and hand viewer and user viewer and a few others but not sample point viewer. When I try to run any of these i get the message
      Open Device failed: DeviceOpen using default: no devices found
      So i dont know if this is because i cant find the three files to copy or if I have messed up somewhere else in the step process. Please HELP! I will be here to answer and questions for my workflow process.
      Thanks a ton guys the info so far on all these boards has gotten me farther than ever before!
    • Feb 27 2013 | 12:13 am
      I recommend you leave that OSCeleton freenect stuff behind. Its old technology. Move up to jit.openni on both windows and mac.
    • Feb 27 2013 | 10:19 pm
      dude you rock! got it up and working with no problem. only one question, the IR camera reads its output matrix as a 1x1 when the others are at 640x480. is this because the IR doesnt actually show up in a window or do I not have something installed/directories arent lining up? Basically everything works, the jit window where the IR is supposed to show up isnt showing anything and the matrix is reading a 1x1. If you know why that is that would be great! thanks again man!
    • Feb 27 2013 | 11:24 pm
      The Kinect doesn't support streaming the Color and raw IR at the same time. The Kinect v1 hardware doesn't have enough bandwidth. You have to choose which one you want and then edit the XML configuration file to enable it. The demo XML file I distribute only streams the Color and Depth data. Please refer to In it you can see changed to the XML config that you can switch to which will stream the IR and depth data. If you have further problem, I encourage you to open a new issue at