LCD - no such object ?

    Jun 17 2010 | 7:55 am
    Hello I'm running max 5.1.4 and I have made a patch which doesn't recognize the lcd-objects - I use 7 of them - the first time I run it when opening Max. Normally I then go into the helpfile of poltocar, copy the lcd-objet which works from there into my patch. Close patch down, save it and reopen the patch. Then everything is fine. It all seems quite strange to me and pretty illogical.. I have made another patch only consisting of a lcd-object and there is no problems.. If I open the testpatch prior to my other patch there aren't any problems either.
    It's no big problem, but a little odd and impractical. I'm curious to know if anybody is familiar with this? Could it be something in my patch which confuses the objects (it's just strange then that it functions if I've opened another patch including lcd or copy it in from poltocar)? Or is it a bug in lcd? It's my first patch with the lcd-object so I haven't tried it in other ways. And even if I have a lcd-object in that patch which is not connected to anything, it still won't work the first time opened..

    • Jun 17 2010 | 8:58 am
      Have you checked to see if you have anything called lcd.* in your search path? I bet you do.
    • Jun 17 2010 | 10:11 am
      aha - so that's what's causing the confusion. Yep, I had named another patch "LCD" in a folder under one of my search paths. I renamed it and now no problems. I had never thought of that. Thanks for the help!