Phasor jumpy when changing sync rate


    Jan 06 2014 | 2:31 am
    Hi,
    Why does phasor jump to a new value when I change the sync rate multiplier? Is there any way to smooth out this jump?
    Ive tried using "line" which does create a ramp, but when the ramp is not working there is no signal.
    A little patch to demonstrate what I mean:

    • Jan 06 2014 | 1:22 pm
      Any1?
    • Jan 06 2014 | 3:40 pm
      Here I have done a patch outlining the difference between phasor, rampsmooth and line.
      Any know which tool is best for the job? Am I using them in the right way?
    • Jan 07 2014 | 12:20 am
      Any 1 want to comment on this? It seems that most of the LFO's in every Max implementation of phasor seem to have a problem with this, so it would be a help to anyone creating synced timings.
    • Jan 07 2014 | 5:37 pm
      Any1 can help poor newtfish?
    • Apr 24 2014 | 11:13 am
      I do not quite well understand you. But what i can tell about your patches, as i see jump happens because of scaling 0 - 1 interval for different note values.
    • Apr 24 2014 | 4:21 pm
      Hi Ivnos,
      Not sure how scaling will affect this.
      Basically, when the phasor sync is switched (say from 1/2 to 1/4), the phasor jumps directly to the position where is should be according to 1/4. Whereas I was hoping to find a way to get it to smooth out that jump (while going back into sync within a short period).
      Abletons own devices seem to do this. I thought it would be something that is common with the usage of phasor sync?
    • Apr 24 2014 | 6:04 pm
      This may not apply to your situation, but have you tried setting the sync mode to off?
    • Apr 24 2014 | 10:14 pm
      Hi NECEQ, if sync mode is set to off, how can I move from 1/2 to 1/4 ? Is it possible to calculate the frequency based on synced values?
    • Apr 24 2014 | 11:13 pm
      I understand what you're talking about all too well. I ran into this problem when coding my "binary" (and then "hex") mod for monomodular. The problem is the sync setting: if you turn sync off, phasor won't jump....but of course then there isn't proper sync. It seemed like a bug, but when I thought about it I realized it was a necessary evil of phasor remaining in sync when changing frequencies.
      The solution I use it to scale the phasor using a custom gen~ object...unfortunately my implementation is pretty application specific so I doubt it would help you. Anyway, just thought I'd throw in my 2 cents.
      a
    • Apr 25 2014 | 2:10 am
      is this what you're looking for?
      it could be made more exact maybe by incorporating delta~ to account for exact change in slope, but was the quickest thing i could think of outside of gen~. you could also cater the $1 timing to zigzag~ better for your specific needs... when i run it at extremely fast tempos it's too fast to tell :p
      (also, 'lock' is supposed to work this way, jumping straight to the new value... it mimics the 'lock' function of the rate~ object... if there was a 'sync' mode to phasor~ might be nice too(waits for next cycle before registering change)...)
      but anyways, hope it helps.