Lions, & lions & lions -oh my!

    Jul 19 2011 | 10:36 pm
    So tomorrow is the day. Any word from the devs as to whether max plays ok with Lion?

    • Jul 20 2011 | 1:45 pm
      yes ... i'd upgrade to lion if I was told there are no issues with max
    • Jul 20 2011 | 6:53 pm
      I've been running Lion for about a week now, and have found no problems w/ Max, fwiw.
    • Jul 20 2011 | 9:08 pm
      I have just finished installing Lion on a Mac mini here and playing with Max and MFL.
      Here are some first impressions.
      Everything seems pretty much fine. MFL is working correctly so far, but please note that Ableton are currently recommending people NOT update.
      Our CP is working , including iLok.If you encounter any problems with your authorisation, please do not hesitate to get in touch with support.
      Lion does not include Java by default. If you see a message asking you if you want to install the Java runtime, please do.
      PLEASE NOTE: this is an entirely preliminary basic walk through., and is not meant at all to be the definitive answer to MaxMSP's Lion compatibility. Over the next few weeks we shall be doing extremely thorough testing of all of MaxMSP's feature set in Lion, and if there are any issues, these will be addressed in the forthcoming Max 5.1.9 incremental update.
    • Jul 20 2011 | 10:09 pm
      Thanks Andrew.
    • Jul 21 2011 | 12:42 am
      I updated my post with new info. iLok is working fine for me.
    • Jul 21 2011 | 2:06 pm
      What's the jitter performance like? I noticed a serious performance hit in Snow Leopard from Leopard (a noticeable few frames of latency in live video) so I'd be thrilled if Lion was at least back to the Leopard speed.
    • Jul 21 2011 | 5:09 pm
      So I noticed a problem today after updating to Lion. Regardless of what input I use (internal mic, Apogee Jam) I get meter-peaking noise. It changes pitch as I change the vector size. I'm also including a link to a movie. Note that you are NOT hearing feedback. This is the audio that comes out of the patch due to corrupt audio input as far as I can tell. Can't seem to shake this no matter what I try (restarts, reconfiguration, etc.)
    • Jul 21 2011 | 6:31 pm
      I don't have problems with audio here. Try deleting your preferences?
    • Jul 21 2011 | 6:49 pm
      Thanks Andrew - Tried deleting ~/Library/Preferences/com.cycling74.* but that didn't solve it. Other apps work so I don't think it's a global audio setting but I could be wrong. Is there an official un-install script so I can do a fresh re-install or is it just the Max folder? Thanks for any other advice.
      EDIT: PRAM reset didn't help.
    • Jul 21 2011 | 7:01 pm
      Your prefs folder is here:
      ~/Library/Preferences/Max5 Preferences Folder
      trash the whole thing. Then download and install the latest version of Max-- it will replace your current install.
      If that doesn't help, send in a note to support at cycling74 dot com
    • Jul 21 2011 | 7:15 pm
      Thanks Dave - no go there as well...also deleted /Library/Preferences/Audio to no avail.
      As I mentioned - other apps work - Live, Wave Editor, etc. when it comes to audio input.
      Each time (in Max) when I change the input in DSP settings I get noise of a different pitch - classic random data writing to an audio buffer type stuff - just as in the movie posted above. any other thoughts? Will keep trying various things...
      EDIT: Creating a new user and launching Max from there causes the same issue. Very strange.
      EDIT: Fresh install also does not fix the problem.
    • Jul 21 2011 | 8:30 pm
      I have an issue with suckah object it give me always 0. 0. 0. 1. with max 5.1.5
    • Jul 21 2011 | 9:13 pm
      Yeah I can reproduce the problem with suckah on Lion.
      We'll get on it.
    • Jul 22 2011 | 12:21 am
      Well this is a bummer - even re-installing Lion still causes it to occur. I'm not sure what to try next. I emailed support. Hopefully Andrew is not support since he's already here. :-)
      Is anyone else having this problem? Thanks!
    • Jul 22 2011 | 12:52 am
      What hardware are you on, as in, what type of Mac is it?
    • Jul 22 2011 | 1:05 am
      Hi Andrew,
      MBP. 2.2 GHz Intel Core i7. 4GB 1333 MHz DDR3. Note that this worked yesterday before Lion - I use this functionality practically daily. Definitely something in the install messed things up. I just also reinstalled Soundflower, Xcode, Lion and MaxMSP itself. I'm sifting through the and found this - not sure if it is significant or if it happens under non-Lion.
      Jul 21 21:01:50 i7mbp [0x0-0x6f06f].com.cycling74.MaxMSP[1493]: cmd line -psn_0_454767 Jul 21 21:01:50 i7mbp MaxMSP[1493]: CFURLCreateWithString was passed this invalid URL string: '/System/Library/Frameworks/CoreServices.framework' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead. Jul 21 21:01:54 i7mbp [0x0-0x6f06f].com.cycling74.MaxMSP[1493]: MaxMSP(1493,0xad1532c0) malloc: *** error for object 0x999a000: pointer being freed was not allocated Jul 21 21:01:54 i7mbp [0x0-0x6f06f].com.cycling74.MaxMSP[1493]: *** set a breakpoint in malloc_error_break to debug Jul 21 21:01:54 i7mbp [0x0-0x6f06f].com.cycling74.MaxMSP[1493]: sqlite version Jul 21 21:01:55 i7mbp MIDIServer[1497]: MIDIServer [1497] starting; arch=x86_64 Jul 21 21:01:58 i7mbp MaxMSP[1493]: CFURLCreateWithString was passed this invalid URL string: '/System/Library/CoreServices/CommonCocoaPanels.bundle' (a file system path instead of an URL string). The URL created will not work with most file URL functions. CFURLCreateWithFileSystemPath or CFURLCreateWithFileSystemPathRelativeToBase should be used instead. Jul 21 21:01:58 i7mbp [0x0-0x6f06f].com.cycling74.MaxMSP[1493]: Max: starting db update Jul 21 21:01:58 i7mbp [0x0-0x6f06f].com.cycling74.MaxMSP[1493]: Max: unable to open [-psn_0_454767] Jul 21 21:02:05 i7mbp [0x0-0x6f06f].com.cycling74.MaxMSP[1493]: Max: db update complete
    • Jul 22 2011 | 1:11 am
      Another note - Process coreaudiod by user _coreaudiod is running @ 0% CPU with 3 threads. When I enable audio in MaxMSP and what is in my video starts to occur coreaudiod jumps up to ~9%-11% CPU with 5-9 threads. This is just with adc~ going into meter~ and nothing more. Removing meter~ makes little difference in these numbers.
    • Jul 22 2011 | 1:28 am
      One more thing - not sure if an issue - coreaudiod is Intel 64 bit but Max is simply listed as Intel (not 64 bit) - was coreaudiod 64 bit before Lion? Does that even matter?
    • Jul 22 2011 | 2:51 am
      Ok Mr Earsmack.
      We'll continue this conversation in support. Thanks for the information.
      We can reproduce this issue and are now working on it in engineering.
    • Jul 22 2011 | 3:55 am
      Hint object does not allow typing in the object it self ( see screenshots) also maxuino does not work it all.
    • Jul 22 2011 | 10:34 am
      Thanks Andrew - I look fwd to hearing from them.
    • Aug 03 2011 | 2:18 pm
      @ earsmack
      i have the same problem!
      (Mac Book Pro 2 Ghz Intel Core i7 4 GB 1333 MHz DDR3)
    • Aug 06 2011 | 12:07 pm
      Hello everyone some information about OS X Lion+MAX 5+OpenNI+OSCeleton. I work on a Mac Mini Core 2 Duo 2.4Ghz 8GB and OS X Lion.
      The latest CMake update works perfectly with OS X Lion.
      The latest MacPorts update works perfectly with OS X Lion.
      The latest OpenNI update works perfectly with OS X Lion. OpenNI Unstable Build for MacOSX 10.6 Universal x86/x64 (32/64-bit) v1.3.2.3 PrimeSense NITE Unstable Build for MacOSX 10.6 Universal x86/x64 (32/64-bit) v1.4.1.2
      Another information for option outputs !THE JOINT ROTATION DATA! you will find here :
      OSCeleton uses 26% CPU on my MAC Mini.
      update avin2-SensorKinect-2d13967 OK!
      I hope this information will help you
    • Jul 31 2012 | 1:17 pm
      I have the same problem. Macbook Air - OSX Lion. Does anyone know how to fix it?
      (MAX 5.1.8)
      SOLVED: Upgrade to 5.1.9