live.remote~ track volume control produces clicks when setting a new id / 'id 0'

    Oct 22 2012 | 5:16 pm
    Hello M4L users, I wonder if you know the behavior, I noticed in the last few days, or if you have any hints: To execute a track-fadeout, I use live.object to get the actual track volume value, then feed a line~ object (which is connected to a live.remote~ object) to this value. Not before the line~ is set to the actual value, I send the id to live.remote~, but nevertheless, a loud click is produced. After the fadeout line is done (fadeout sounds good), I free the live.remote~object ("id 0" in second inlet). This produces a second click. I even tested with many delays etc - but without success.
    I'm not sure, but I use this technique already for a while and I suppose, that it worked some time ago - but now I'm insecure... Maybe someone outside could verify the behavior with the attached amxd file, which reproduces the undesired effect. Thank you in advance, Martin

    • Oct 22 2012 | 5:31 pm
      I forgot to mention my system / software versions: -Mac OSX 10.6.8 -Max 5.1.9 -Live 8.3.4
    • Mar 28 2015 | 3:35 am
      Yes, this is definitely happening all the way up to Max 7.0.2. This happens just with a basic live.remote where the ID is changing. If Audio is playing, there will be an audible click when the ID is changed. In your case, the click is happening even when no audio is playing (since the line object has reduced the volume). Hopefully C74 can shed some light on this behaviour :/
      Also noticing that changing the buffer on the soundcard improves the clicks. Setting to 1024 samples makes the clicks much better, but they're still there.
    • Mar 28 2015 | 10:57 am
      I'm indeed frustrated about this bug, because I first reported it in October 2012 (known as ticket #3713) and it was never really fixed. The problem is, that this bug has to be worked out by both sides: Cycling74 and Ableton. In March 2013 Cycling told me, that they fixed it - but it was worse than ever. I don't remember it well, but there once was a version, where this was fixed. But one or two versions later it came up again - and it never changed up to now. I always wondered, why nobody else had trouble with this. Due to a lack of time, I didn't go further with it - but in the next days, I will contact cycling and Ableton support again.
    • Mar 28 2015 | 2:40 pm
      Yes, the problem seems the same across the board. For instance testing on the stock XY pad that comes with Ableton 9. There is functionality where the live.remote attaches the ID upon finger pressing on the XY pad and sends an ID 0 when the pad is released. If you press up and down on the pad even remotely fast you can hear clicks.
      Quite frustrating that the only way to get rid of it is to up the buffer size to around 2048 samples and that's with a RME soundcard (which are v low latency for everything else).
      Imagine in a live setting this could sound really bad coming through the speakers.