loadbang not working with multislider/pattr


    Feb 11 2014 | 2:54 pm
    Hi,
    I have the following patch, but for some reason, when I reload it (in live) I have to physically doubleclick loadbang twice, to get the plot/graph to show up.
    Id be really grateful if someone could explain why the Loadbang is not making it's way to the multislider/plot.
    I have added as an attachment because the forum wont let me add the encapsulated code
    Its' the attachment with a 1 on the end. Try drawing a curve into the right hand multislider, then save the set, then recall. You will have to click loadbang twice to get the multislider to show in the plot graph

    • Feb 11 2014 | 3:03 pm
      did you try a [defer] or [deferlow] after the loadbang ? i had dome issue with a graphical object (bach.roll in the bach library) not updated by presets sent by loadbang, the mentionned obejcts did solve. The problem, if i may hazard a guess, is that the graphical objects are constructed in a lower priority thread at patcher's initialisation ? So if you need messages sent to said graphical object, they should be sent after it's constructed ?
    • Feb 11 2014 | 3:27 pm
      Hi Vichug, yep I tried deferlow, and also ive tried delaying the bang for up to 5 seconds, along with uzi to get multiple bangs to come out. Its still not happening. This is a really weird one, I have no idea why its not working :/ The other thing I cannot understand is why I have to click loadbang twice????
    • Feb 11 2014 | 3:59 pm
      I forced it to work a different way, by making the loadbang go directly into the multislider, to output all the sliders at once, then listfunnel straight into the poke~
      However, I have to delay it by 1000 ms (cannot do 500ms even) I have no idea why it needs to wait so long before it works. Makes me worry that this will react differently on different setups.
    • Feb 11 2014 | 6:14 pm
      You could try replacing [loadbang] with [live.thisdevice]. In theory it sends a bang when the device is completely initialized.