lot of bugs with vidéos / AVF vs QT engines


    Feb 25 2015 | 4:29 pm
    Hi Everyone,
    I'm a little bit confused with the new Max 7 video capacity. I'm using Max 7.0.1 on a Mac Book Pro with Yosemite.
    How to describe the problem I working on a patcher where I use lot of picture and videos with alpha layers.
    For now I've tried PNG on videoplanes, it works well with AVF engine but it doesn't work at all with QT engine. For videos I've tried Quicktime PNG codec, it works well on my windows machine but it on yosemite it works very slowly with AVF nor QT engine. I've also tried Quicktime Animation codedc, whick works well on yosemite but only with QT engine (wich doesn't work for the PNG pictures).
    So the question is WTF ? or in other words what happen here ? is it possible to make it work well anyhow ?
    Sincerely Sylvain

    • Feb 25 2015 | 7:53 pm
      Same here.
      What I've noticed is that I never got problems when using it with the [jit.world] object but I do when I'm using it with the regular [jit.gl.render] setup.
      Doesn't really make sense but that's what I've noticed. Are you using jit.world or jit.gl.render
    • Feb 26 2015 | 1:17 am
      It would really help out if you guys could send along a stripped down example patch and sample images that are failing, along with steps to reproduce to Support. With that it will be much easier for us to track down what exactly is happening.
    • Feb 04 2016 | 1:11 am
      Hi,
      reviving this thread with a stripped down example, as I'm really stuck by this issue at the moment.
      Step to reproduce : - open the attached patcher in both Max 6 and Max7 - put the jit.window side to side - observe the glitch - observe the tone difference
      I somehow solved the glitch problem I had on other [png] images by re-saving them with gimp, but what options are good or not remains mysterious to me. It also seems to disappear when using the qt engine rather than avf. If you have any idea to solve this (what good codecs / settings for options such as "saving color values for transparent pixels" and such...)
      I intentionally used brush02alpha.tif in the attached example, rather than my own glitchy png, as it is part of the Max distro.
      The other issue is nastier and does *not* disappear with qt/avf engine switching. There is a brightness/blending difference between to identical png (as seen on the file provided along with this mail).
      Max 6 is latest version. Max 7 + system : { "version" : "Version 7.1.0 (667771f) (32-bit mac)", (64-bit doesn't help) "platform" : "mac", "arch" : "x86", "osversion" : "Mac OS X Version 10.10.5 x86_64", "scheduler_in_audio_interrupt" : "off", "eventinterval" : 2, "overdrive" : "off", "videoengine" : "avf", }
      In case you don't get the issue on your side, I attached to this post 2 snapshots of what i get here (left is max6 jit.window, right is max7's jit.window).
      Please help!
    • Feb 04 2016 | 8:07 am
      Further info from what I experienced here : - TIFF images with alpha layer will blend correctly in Max7 under both qt and avf engines *but* may glitch with avf in some cases - PNG images with alpha layer will blend wrongly in Max7 under qt engine *but* do not seem to glitch
    • Feb 04 2016 | 3:58 pm
      @siteswapjuggler : The brightness bug looks like one I experienced in Isadora when piping some visuals from a M4L device to Izzy using Syphon. It was caused by the alpha channel not being properly added in the first place, but it may be something completly different...
    • Feb 10 2016 | 6:18 pm
      thanks for the report Vincent. i'll see if i can figure out what's going wrong here.