M4L device not initializing properly outside of editor.

    Jun 17 2014 | 7:55 pm
    I have a device which does some straightforward querying of devices in the same track. Initialization works great when triggered or re-triggered from a button in editor mode, but I can't get it to initialize properly when run outside the editor and only in Live. I tried using [live.thisdevice] to kick off the init chain, and also tried adding a 3000ms delay but it didn't help. Everything seems to work if I trigger the same init chain with the click of a button stored in presentation mode.
    What are the common pitfalls with initializing M4L devices? Also, what are some ways to debug this sort of thing since print won't print to the max window when using it from Live?

    • Jun 18 2014 | 1:04 pm
      right-click on the header of a m4l device, you can open the max window in non-edit mode as well. you'll probably see a live api error message. sometimes conditions are different in editor mode, only the closed device is really implemented in the Live thread. the common case is a missing [deferlow] especially after observers triggering another api thing. O.